Hyundai Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hyundai i40 1.7 CTDI Blue drive
Hi Guys.
Last week I've change radiator as my previous one was leaking and installed a new one however I have an problem.
I will try to explain it best I can an if you can help me will be much appreciated.
After filling radiator with coolant fully I've notice after driving a bit that coolant level in reserve tank went up drastically after each drive.
When I start engine I can hear coolant movement (it's like moving vertically half full water bottle) but only at beginning of car movement.
I've "bleed" cooling system twice now but there is still an issue with cooling system.
When engine is not running there is no issue but when start's cooling level is going up approx. 1l. (half bleeding bottle as per photo) and some bubbles are coming out
Heater was setup up to max however cold air was blowing when static (when I start to drive heating is coming on that's meant that thermostat is ok?) during this test and some coolant went as well to reserve tank.
After turning engine off and not even 1 minute after that all coolant is going back to the system.
If you have any ideas how to deal with this issue please let me know ASAP.
Regards
452269
 

·
Registered
Joined
·
2,290 Posts
lots of shops have this or something like it:
but you need shop air. it is foolproof, some shops specify all their techs use a vacuum tool. it will pull out all the air, and refill it fully, even pulls open the thermostat. no need to bring it up to operating temps and "burp"
 
1 - 2 of 2 Posts
Top