Hyundai Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Front Intermittent wipers not working on 2000 Hyundai Accent 2G. The wipers work fine on normal and fast speeds and park correctly when switched off so I'm sure there is nothing wrong with the motor or the park switch within the motor unit.

My best guess is that the fault is most likely with the intermittent relay or an open circuit in the wiring.

Problem is, I can't find the relay! Does anyone know where the relay is located - or is it integrated into the switching unit on the end of the stalk?

Also, does anyone have or know where I can find a wiring diagram for this model?

Any suggestions or help appreciated!

Tanks.
 

·
Registered
Joined
·
2 Posts
Hello

I have a similar problem with my 2004 coupe. The intermittent wiper stops half way through a wipe and then starts at the next wipe period completing the wipe and then stops half way again.
I believe this is due to the micro switch attached to the wiper motor. It was surprisingly easy to get at on the coupe once I found the maintenance manual online explaining where it was. The switches are in the form of three wipers that press down on circular track inside an easy to un-click housing. Mine are smothered in grease when I took it apart, which was pushing a wiper away from the track. I bent the spring finger down which got it working again, unfortunately it has now gone back to its bad old way, so I'm going to give it another go and remove a bit more of the grease. If that fails then maybe I will need a new wiper motor assembly.

Good luck

gazzer
 
1 - 2 of 2 Posts
Top