Hyundai Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey everyone new to the forums been looking threw board after board and really cant find anything of this topic. I have a 2001 Hyundai accent GL automatic 1.6, and well when I'm city driving 50-55 my rpms are about 3.5K? I'm guessing something is wrong with my transmission or maybe a sensor? I do know for a fact my transmission fluid level is scary high and today I'm going to drain the old fluid that's never been changed I'm sure I got this car off craigslist a year ago with 113k miles on it...so I'll report back to see if anyone has any answers if I don't end up fixing this problem myself lol...
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #2 ·
so I did a transmission fluid change and got it at the right levels its shifting much better and is a lot more silent but I'm still at 3k+ going 50 mph city driving. any clue?!
 

·
Registered
Joined
·
42 Posts
Well, considering this is a little 4 Cylinder car, id like to say 50-55MPH and 3-3.5K RPM would be normal...

You could also have an engine that needs a tuneup...when was the last time plugs, wires, air filter, and oxygen sensors were done? Maybe add some fuel cleaner to it?

That's the only other thing I can think of if the transmission is shifting fine...unless its not going into overdrive?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
yeah all that stuff you mentioned was all replaced within the pass six months I love working on my car! I do have an overdrive problem tho, and its one of those you got to click the button to engage the overdrive. when my car O/D light is off once I get up to 40-45 it kinda feels like it went into to neutral and red lines so I never have it in overdrive... when I'm driving 45+ and engage overdrive it goes into overdrive and then about 2 seconds later starts slipping and red lines and jerks really bad.. I'm guessing this is a expensive thing to fix :{. also sucks cause I cant drive on the highway going 65-70 I'm at 4.5k rpms and my engine sounds so horrible loud.
 

·
Registered
Joined
·
6 Posts
No, just because the engine is small does NOT mean that you should be having 3-3.5k at 50-55.
If I drive a consistent 60 I'm usually at 2.8-3k.

Other than having OD on, there's not tons that I can suggest. I'd say to check your idling speeds, because that could be one part of the culprit.

Have you been regular with oil changes and tune ups?
 

·
Registered
Joined
·
6 Posts
One more thing to look at, check is maybe your torque converter clutch isn't locking up.

Also, has your Accent ALWAYS revved this high, or is it something that just showed up not too long ago?
 

·
Registered
Joined
·
17,552 Posts
You have a 4 speed trans, count your shifts.

OD is 4th, you can select OD off and hold 3rd gear.. OD on, trans should go from 3 - 4 if conditions is correct.

If it goes from 3 and engine flares, you got trans concern...

You say you changed ATF.... Did you actually remove the oil pan, or was it a simple drain and fill ???

Remove the oil pan and see if you find bits and pieces of a "TORRINGTON" ® roller bearing in the oil pan...
 
1 - 7 of 7 Posts
Top