Hyundai Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
108 Posts
Discussion Starter #1
Does anyone know why moments after gasing up it registered 3/4 tank and then I ran another errand and shut it off and then it read just above the empty mark???? Is been doing this off and on for about 2 mo. Not every time what is it I can check.. No check eng light on is this some sort of sensor?
 

·
Registered
Joined
·
304 Posts
Sending unit inside the tank could be bad or just needs to be cleaned. Gasoline with too high a sulfur content will coat the wires of the sending unit giving a false reading. This happened to me once when I got a bad tank of gasoline from Shell. Go to the auto parts store and ask them if they have a fuel cleaner that will remove sulfur from the sending unit. Just pour it in your gasoline tank and drive. Make sure you have a full tank of gas and run the tank till almost empty.

This is the cheap choice before looking any further into it.
 

·
Banned
Joined
·
1,850 Posts
then it read just above the empty mark????
Good suggestion above.
I recommend a double dose of Berrymans B12 Chemtool.

If that doesn't do the trick, you probably are looking at replacing the sender unit. Could be a loose connection too.

And, have to ask, you really do mean just above EMPTY, right.......and not just above FULL ?? The latter is pretty much normal as the indictor is heavily damped and takes a while to come up to full.
 

·
Registered
Joined
·
108 Posts
Discussion Starter #4 (Edited)
Cool.. I will do that.. Thanks for suggestion. Yes I read just above empty.. At one point the low fuel light came on... And before I even gas up I had at least just below half but it was reading just above the empty when I put 20.00 in and gave me 3/4 I was thinking it was a sticky float or a sensor.
 
1 - 4 of 4 Posts
Top