Hyundai Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Last night while engine was warmed up after driving and was sitting in a parking lot with my vehicle which it sounded like my car was accelerating. I looked at my rpm's and they kept fluctuating between 750-1250. I turned of my headlights, radio, heater and that did not change a thing. A few months ago I was sitting at a red light when my rpm's did the same thing but that i felt like i had to really press on the brake hard to keep it from going forward and then my temp guage started rising to close to red zone and as soon as i pulled out and drove, temp went down and idle was fine after that until last night. I noticed this morning driving to work that while sitting at a light that my rpm's were fluctuating between 500-750 and when I got to work I would put it in park rpm would go to 1000 and then go back down to 750 and stay. Same when I put it back into drive. I called Hyundai, they call help me figure it out for a fee of course. Took my car to autozone and no codes came up. I have 96,000 miles. I am beating my head because everyone I have asked is stumped and I don't want to start replacing part after part to only have it not fix the problem. I just spent A LOT of money replacing the timing belt, water pump and tensioner pulley, I really do not want to start forking out money left and right to figure what is wrong

Anyone have idea or have experienced this? I have searched and searched and cannot find anything
 

·
Registered
Joined
·
1,282 Posts
What you wrote about your temperature gauge makes me wonder if you have a problem with the cooling system - low coolant level or very old coolant mixture. If the engine starts overheating, the ECU (Engine Control Unit) would bump the engine speed to run the water pump faster and try to cool things off. Also, if it's low of coolant, the heater will stop working at low engine speeds.

Check the coolant level in the reservoir. If it's low or empty, just put some water in it for the time being and see if the problem improves. If it does, you'll know you're getting warm. Uh ... pardon the pun. :whistling:
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
That makes sense now that it was explained to me, I do have a very slow radiator leak I mean EXTREMELY slow so that solves why that happened. But today I had some weird things go on. At start my rpms drop to like nothing (as if I shut off my car) but it doesn't hesitate or stall, then the rpm's shoot up to where they should be. Also as I am slowing down or braking my rpms drop pretty abruptly and then almost like it's catching they go back up. It's like something is telling the rpm's, wait wait your too low get back up (i know that is such a girl thing but that is what it felt like..haha) and when it does this it almost feels like there is a drag. I am starting to think my TPS but from what I read people have problems with rpms going up not down. I am stumped, the car will be gone in January but I need it to make me till then without taking it to Hyundai to have the over charge me. They wanted double to change my time belt, water pump and tensioner then what anywhere else charge. Any help is greatly appreciated
 
1 - 3 of 3 Posts
Top