Hyundai Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Anybody have this problem.
I have a 2008 Entourage and after driving the van for about 5 mins the van’s idle will surge up and down when stopped, like at a light. The van revs between 550 and 750 rpm, which doesn’t feel normal. The A/C is not on and the van has 30,000 km on it. If I put the van in park or neutral when it starts to happen the rpm stays right at 650 rpm, no surging. When I put it back in drive or reverse again it will start surging again. I took it to the dealer to look at it but they didn’t find anything and said they couldn't reproduce the problem. Just wondering if anybody else has had this problem?
 

·
Registered
Joined
·
17,552 Posts
Have the PCM update # 173 and see how it acts.

May try and clean throttle plate (can of carb spray and toothbrush) if it had debris on it or in bore
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #3 ·
Not sure if I got the PCM update or not. I will check with the dealer next time I'm in. I wouldn't think the throttle would be dirty with only 30,000 km on it, but I guess you just never know. Thanks for the reply.
 

·
Registered
Joined
·
17,552 Posts
QUOTE (Rob22315 @ Jun 1 2010, 04:50 PM) index.php?act=findpost&pid=328557
See if they'll do TSB 09-FL-003-2 which I just posted above.

They may not just arbitrarily do a TPS replace without prior authorization without supporting DTC's documented on GDS printout to match the TSB repair...

The most current re-program is #173 for the 2008, has overlapping codes covered in both TSB

I would ask for #173 and give it a run... With the 09-FL-003, the concern will be MIL, ESC?ABS lights, and no accelleration/limited power...
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #6 ·
I just wanted to give everyone an update. After about 4 months my van finally set the check engine light with the DTC codes P2135 (Throttle position sensors ½ voltage correlation), P1295 (ETC System Malfunction – Power Management) and P2106 (ETC System Malfunction – Forced Limited Power). So when this happened the van went into “limp home” mode and I could only go about 20 km/hr. I stopped and turned it off and back on and then I was fine to drive home with the check engine light on. So it looks like I had the TSB 10-FL-010 which is the updated version of TSB 09-FL-003-2. Repair Action is a replacement of the Throttle Position Sensor (TPS) and an ECM software update. Now that I got the repair my idle is perfect with no surging. So if your idle is surging and you don’t get any engine light it could be the start of this TSB.
 

·
Registered
Joined
·
1 Posts
I own a 2009 Kia Sedona (Canadian Version) and have noticed it has an issue with idle when cold only in Neutral or Park. The idle surges between 400-750 rpm. It was noticeable enough to dim certain electronics and fans with the heating system. The car almost felt like it would stall. It has not thrown any Codes.

I took it to the dealer and they said there is a "Service Action" available which involved an ECM upgrade but no mention of TPS sensor change.

I got this Service Action completed and now the idle surges at a higher rpm. It has fixed the issues with the electronics starving for power. The car no longer feels like it will stall.

I think the TPS sensor is of a faulty design and about to fail. I think it will start pulling codes soon. No mention of this on the KIA side things. Not sure what to do at this point. I cant replace the TPS myself as it requires further ECM changes.
 

·
Registered
Joined
·
17,552 Posts
Replace the TPS if it of the old flavor.. you can do that if carefull.. part is maybe $36 US dollar.. We keep maybe 5-6 on shelf all the time.

I have pics of new & old part if you wish to inspect yourself to if you have latest version.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top