Hyundai Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi all,

I picked up my lovely blue car - brand new basically zero klms odo - a few days ago and have been driving it fairly respectfully for the run-in period (1000klms). I’ve done just over 250klms in these few days, but unfortunately city driving means city traffic, so while I’ve been careful to avoid high revving and hard braking there were the inevitable driving reports (I think I’m going to get jack of these lol). I think a grand total of 5 or 6 hard braking incidents (4 of those times to avoid absolute numpties on the road) and 2 hard acceleration incidents (I’m sure one of those was turbo lag kicking in). I think very few times considering the mileage I’ve done in 4 days, most of it in 4 long trips to the other side of the city.

So... I’ve been getting quite a whiff of something after these long drives, and am hoping it’s just the tyres settling in?? I’m hoping it’s not any engine issues. I’m new to Hyundais, I’ve had Subarus and VWs in my 18yrs of adult driving - all but one of those six cars were brand new, and I don’t recall this smell for any of them?

Anyone have any answers or experience? Put my mind at ease, please? Lol
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
It smells more metal than rubbery. Like it doesn’t smell like burnt rubber, my fiancé thinks it may be brakes wearing in. It doesn’t smell ozone-y as if it were electrical...

Do you mean stickers from item parts from the factory that has been taken off for delivery, but perhaps with some glue residue being burnt off from the car being used?

Thanks so much, I hope I’m overreacting. As I said this is my first Hyundai and I really don’t want to regret my purchase.
 
1 - 3 of 3 Posts
Top