Hyundai Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My car when I pass more than 50 Mph, my transmission goes down to 3rd gear from 4th gear and I put my OBD scanner and I don't remember exactly the code I think it is P0721 but I'm not sure, but I remember that the scanner seems to me the output speed sensor OSS was damaged, this is the sensor that I bought and changed 42621-39052, and it gets stuck between the 2nd and 3rd engine and I need to turn it off so it will recognize 1st and 4th again.

When I delete the code with the scanner everything is fine but when I exceed 50mph the problems start.

Thank you for your answers.
 

·
Registered
Joined
·
2,328 Posts
It's going into fail safe with manual 2nd and 3rd available I assume. Yes when you cycle it clears the code and the TCU operates the solenoids normally again but when that code triggers it's going back to failsafe
 

·
Registered
Joined
·
2,328 Posts
can we get more info on year, motor fitted and your location? I just want to see which box is fitted. Interesting it's above 80kph when it triggers. I've had sensors fail on a A4CF2 box , i30 but it shut the box down as soon as it shifted. Left me with 2/3 using the shifter
 

·
Registered
Joined
·
2,328 Posts
You may have to investigate the VSS. looks like at higher speeds above 18MPH it does a comparison between the VSS and the OSS. a significant difference will also trigger the same code. You may want to confirm what the exact code is, I see P0720 for OSS cct .

The VSS is likely on the differential housing.

Also check wiring is good, no corrosion etc

That's all I can think of but I'm a little puzzled it does not mention the VSS in the likely cause list for P0720
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #7 ·
can we get more info on year, motor fitted and your location? I just want to see which box is fitted. Interesting it's above 80kph when it triggers. I've had sensors fail on a A4CF2 box , i30 but it shut the box down as soon as it shifted. Left me with 2/3 using the shifter
Thank you very much for your answers, as I see the engine code is G4GC, 2000 C, I imported this car from the United States to Guatemala, the code is P0721 and it happens as you say when I remove the battery the code disappears and returns only with the condition that it goes over 80 kph, I have driven below that speed for 15 days and the Check Engine light is not turn on and the car works perfectly.
 
1 - 7 of 7 Posts
Top