Hyundai Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi All

I have a problem with my 2004 Hyundai Trajet 2.0 Diesel Automatic which is driving me nuts and is as follows when you start the car up it has a loud knocking noise from top end and also lots of white smoke from exhaust.
Also oil pressure light was on as well ( but i later tracked this down to a faulty oil pressure switch)
I have removed injectors and cleaned up tips as looked very heavily carboned up and checked cam shaft to make sure no cam lobs were worn all look ok built back up but still the problem percists. Just looking for any one out there who might no the answer or can offer any advise it would be gratefully recieved .

Thanks in advance for any help :thumbsup:
 

·
Registered
Joined
·
59 Posts
I suggest taking the injectors to a diesel injection specialist for testing. Just cleaning the tips doesn't really confirm anything.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Hello have just checked a few other things on the car

Found the main wire to glow plugs had been trapped under rocker cover and has barred it self resulting in a blown 80 amp fuse

also 2 x injectors have one part number and the other 2 have a diffrent number

checked cylinder compresion was found to be ok

the milege on car is 155,000 miles

starting to wonder if injectors have been changed or someone has mixed them up as only bought car 2 weeks ago as a non runner

to use as my trajie petrol needs 2 new back trailing arms which appear to be on back order from factory oh the joys

any one got a clue to where to go now



:thumbsup:
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Here a little up date

Have had all my injectors tested by a specialisit but all came back as good :right:

so have stripped cam shaft out to check camshaft wear is within spec

checked all cam follwers all moving ok with no sign of damage

checked all bridge pieces same to damage visable

removed hydralic lifters look ok (but how can you test them ????)

cut open oil filter to check for oil fillings of maybe worn engine component was ok not any worse than normal wear and tear

oil drained in to a clean tray no rough bits or metal filing in it

Please Please Please some one come up with a possible cause

:)
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
:( Well thats it i have got to the bottom of the fault

when i built up after more checks and found it was still knocking i stripped the sump off

and found that # 2 big end bearing had gone and crank is total u/s deep scoring and heat marks :( :crying:

so it ill be a another engine then if i can find one that wont break the bank

:essen37:
 
1 - 6 of 6 Posts
Top