Hyundai Forums banner

1 - 9 of 9 Posts

·
Registered
2013, Hyundai Sonata GLS 2.4ltr
Joined
·
12 Posts
Discussion Starter · #1 ·
Hi, I am having a strange issue in my sonata 2013. The wiper, washer and blower sometime stop working while driving. Gets back to normal after some time all by itself. Everything else like AC switch, radio, clock etc., are good. Any ideas of what the issue could be? My guess is that it may be some sort of a main supply or ground problem, but I do not have a wiring diagram.
 

·
Registered
2013, Hyundai Sonata GLS 2.4ltr
Joined
·
12 Posts
Discussion Starter · #2 ·
I checked the 2011-2014 sonata service manual on hsguide, but wiring info is minimal in there. Any idea where I can get one. If someone could post the diagrams for wiper, washer and blower, would be appreciated.
 

·
Registered
2013, Hyundai Sonata GLS 2.4ltr
Joined
·
12 Posts
Discussion Starter · #3 ·
Today we had some snow (in late April!). Fortunately the wipers continued to work. Really stumped on this issue. Thinking of opening the steering trims this weekend and check all electric sockets running from the ignition switch to the fuse board. These intermittent problems are so hard to troubleshoot :( Any ideas would greatly help. thx.
 

·
Registered
2013, Hyundai Sonata GLS 2.4ltr
Joined
·
12 Posts
Discussion Starter · #4 ·
Today, I removed the lower panel under the steering. I also removed the steering shrouds. Pressed all connectors in the steering column including those of the ignition switch, wiper multi-function switch, etc. None of the connectors were loose, so I doubt that the problem is fixed. I will just have to wait and see if the issue comes back again.

By the way, I am impressed with the quality I saw inside. After eight years, not a single sight of rust on any metal plates or bars (I live in Montreal Canada where we use salt on road). The plastic and rubber are of good quality and still soft, the wire harnessing and connectors are very well done. Easy disassembly. All screws and clips were easy to access. Well done Hyundai!

If anyone has the electrical guide (wiring diagrams) of this car, please let me know. As I mentioned earlier, the 2011-2014 sonata service manual on hsguide has minimal wiring info.

Thx.
 

·
Registered
Joined
·
140 Posts
I would look under the hood for a loose or corroded "ground" connection to the body very close to the wiper motor and blower motor. The 2 return wires from the motors may be in the same terminal lug under a bolt. Check for paint under the lug, scrape it off and use a conductive grease on the exposed metal.
 

·
Registered
2013, Hyundai Sonata GLS 2.4ltr
Joined
·
12 Posts
Discussion Starter · #6 ·
I would look under the hood for a loose or corroded "ground" connection to the body very close to the wiper motor and blower motor. The 2 return wires from the motors may be in the same terminal lug under a bolt. Check for paint under the lug, scrape it off and use a conductive grease on the exposed metal.
I checked all the ground connections that I could find on the fire wall. All connections seem to be ok. No rust.
 

·
Registered
Joined
·
140 Posts
Have you added more torque to the bolt at the ground and wiggle the wires for a broken connection, while the blower and wipers are operating. It could be a loose connector under the dash, too.
 

·
Registered
2013, Hyundai Sonata GLS 2.4ltr
Joined
·
12 Posts
Discussion Starter · #8 ·
Have you added more torque to the bolt at the ground and wiggle the wires for a broken connection, while the blower and wipers are operating. It could be a loose connector under the dash, too.
Its not only the blower and wiper. The windshield washer also stops working, which is far away from the firewall/dash and probably ground through the engine frame, so I doubt it is a grounding issue.
I removed the steering shrouds and lower panel and pressed all connectors a few days ago. Nothing was loose. Did not wiggle them though.
I googled a little bit and it looks like that there is an sonata electrical troubleshooting manual 2011 from Hyundai. Any idea where I could buy that?
 

·
Registered
Joined
·
140 Posts
The manuals for the electrical systems, leave a lot of gaps... You may try swapping some of the relays in both of the power distribution / fuse boxes. The common is with the ignition powered down the wipers are off and so is the blower motor. It could be a bad contact on a relay. I could not figure out which one... Just a guess, good luck!
 
1 - 9 of 9 Posts
Top