Hyundai Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Great being here. I own a used Hyundai Getz 2007 model. I just purchased it from the dealership about a week ago. First I realized the car wasn't accelerating enough. I changed plug but still not working, I changed water pump. But still not accelerating properly. I changed disc plate still not accelerating.. I changed crank shaft bearings still car not accelerating. The car can Rev up alright but can't accelerate properly. What could be the problem. Has anyone encountered any problems like this with a Getz and how did they solve it. Thanks
 

·
Registered
Joined
·
2,877 Posts
It may be something like a blocked exhaust. I suggest you get it scanned for possible faults before continuing what your doing. Playing parts darts.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I Had it scanned but no error codes were recorded. No Check engine light was on. Exhaust is fine. Had it checked both front and back. And also was hearing some tapping noise in the engine. What could this be. I'm confused
 

·
Registered
Joined
·
2,877 Posts
Do you have any sort of warranty? If so back to the dealership. If not more info is required. How do you know the exhaust is not blocked? Is the car manual or auto? Is the disc plate a clutch plate?
 

·
Registered
Joined
·
5,569 Posts
You tore down the engine and replaced the crank bearings to help with acceleration?
 

·
Registered
Joined
·
2,877 Posts
Looking at a pic of your engine I see it's got a timing belt. Would pay to check the cam timing. I think the list of things done was not trying to fix the loss of power but yea the crank bearings seems over the top.
 

·
Registered
Joined
·
2,877 Posts
You should also put a vacuum gauge onto the intake manifold and see what it's got at idle. should be around 20 21 inches. Do this before pulling cam covers off.
 
1 - 9 of 9 Posts
Top