Hyundai Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a hyundai accent from 2008 and I have a problem with the check engine optimization have a miss fire error the codes are p300 multiple cylinder miss fire, p301 miss fire on cylinder 1, p303 miss fire on cylinder 3 and p304 miss fire on cylinder 4, I all ready change the all the injectors and sparks and all ignition coil, so the car works fine when I'm driving on the highway but when I stop to a stop after 30 seconds the engine starts to run in just 3 cylinder in order to work again fine I have to stop the engine and start again but if I stay on stop after 30 seconds will do again the same thing..anyone has any idea what could be I think is something electrical becouse I can't see anything else then that a sensor or something I don't know
 

Attachments

·
Registered
Joined
·
882 Posts
can be bad ECU connection, brush all terminals and ground wires. Or you can drive to Hyundai dealer and pay around $120 to fix connection problem
 

·
Registered
Joined
·
13,373 Posts
I have a hyundai accent from 2008 and I have a problem with the check engine optimization have a miss fire error the codes are p300 multiple cylinder miss fire, p301 miss fire on cylinder 1, p303 miss fire on cylinder 3 and p304 miss fire on cylinder 4, I all ready change the all the injectors and sparks and all ignition coil, so the car works fine when I'm driving on the highway but when I stop to a stop after 30 seconds the engine starts to run in just 3 cylinder in order to work again fine I have to stop the engine and start again but if I stay on stop after 30 seconds will do again the same thing..anyone has any idea what could be I think is something electrical becouse I can't see anything else then that a sensor or something I don't know



How old is your battery?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
I have a hyundai accent from 2008 and I have a problem with the check engine optimization have a miss fire error the codes are p300 multiple cylinder miss fire, p301 miss fire on cylinder 1, p303 miss fire on cylinder 3 and p304 miss fire on cylinder 4, I all ready change the all the injectors and sparks and all ignition coil, so the car works fine when I'm driving on the highway but when I stop to a stop after 30 seconds the engine starts to run in just 3 cylinder in order to work again fine I have to stop the engine and start again but if I stay on stop after 30 seconds will do again the same thing..anyone has any idea what could be I think is something electrical becouse I can't see anything else then that a sensor or something I don't know



How old is your battery?
The battery is new
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
can be bad ECU connection, brush all terminals and ground wires. Or you can drive to Hyundai dealer and pay around $120 to fix connection problem
I tried to clean now the ecu connection it seemed that helped a little bit,like the check engine disappeared and appeared again after like 1 minute and when I stopped the engine and started again the check engine disappeared again but after a 1 minute appeared again so I'm thinking now that the ecu is the problem if it does like this
 
1 - 8 of 8 Posts
Top