Hyundai Forums banner

61 - 71 of 71 Posts

·
Registered
Joined
·
11 Posts
No need to drain the coolant, you will loose a little bit but nothing major. I put a small plastic bag over the hoses and secured it with a rubber band. Just remember to refill it when you are done, then run the engine with the radiator cap open and the heater on full hot to get the air out. It will bubble and carry on for a while and the level will drop but just keep adding coolant until the level is no longer dropping.
 

·
Registered
Joined
·
2 Posts
Sorry to dig this old thread up (again!). I have just removed and cleaned my EGR, wasn't really causing me any problems but mostly because I wanted to get to the oil / air separator which is the black tube coming out of the crankcase and going into a pipe leading to the intake.


I seem to be getting a lot of oil mist going back into my intake, as although I have a new turbo I still see oil mist going into the intercooler (which as a small crack in it so the oil ends up on the engine cover), so thought this separator could be to blame. It seems there is no mesh / filter inside this separator, does this seem correct? I tested it by putting a small bolt into the inlet (that attaches to the crankcase) and it came straight back out the exit (which carries the air back to the inlet). Therefore I cannot see how it separates the air and oil.


Has anyone ever had any trouble with this separator? Can it get blocked in the return pipe to the sump meaning oil is blowing into the inlet?
 

·
Registered
Joined
·
25 Posts
Hi everyone, thank you so much for all the information you shared because of these i've successfully cleaned my egr and maf sensor does any of you guys have cleaned your pcv valve? thank you so much in advance and it will be really appreciated if you share your instructions and tips with photos cleaning your pcv valve.
 

·
Registered
Joined
·
38 Posts
Gave my EGR valve a clean on the weekend.

Surprisingly, the actual chamber section with the tubes wasn't to bad, a light coating of carbon buildup which was easily cleaned.

The Valve section itself was jammed. I couldn't open it with hard finger pressure, pushing down from the top where the actuator would normally I got nothing. No movement whatsoever, seized/jammed.

I soaked the valve body in a combo of degreaser/diesel/solvent and it's now super smooth with good sprung resistance!

Car is flying along nicely with EGR clean and new Injectors!

The pic of the valve body close up shows the valve after being soaked, it's still got gunk in it, but it was starting to open.
 

Attachments

·
Registered
Joined
·
2 Posts
Sorry to dig this old thread up (again!). I have just removed and cleaned my EGR, wasn't really causing me any problems but mostly because I wanted to get to the oil / air separator which is the black tube coming out of the crankcase and going into a pipe leading to the intake.


I seem to be getting a lot of oil mist going back into my intake, as although I have a new turbo I still see oil mist going into the intercooler (which as a small crack in it so the oil ends up on the engine cover), so thought this separator could be to blame. It seems there is no mesh / filter inside this separator, does this seem correct? I tested it by putting a small bolt into the inlet (that attaches to the crankcase) and it came straight back out the exit (which carries the air back to the inlet). Therefore I cannot see how it separates the air and oil.


Has anyone ever had any trouble with this separator? Can it get blocked in the return pipe to the sump meaning oil is blowing into the inlet?

Hi Rob, i have the same problem with my SF. Did you end up resolving yours or any suggestions? thak you so much.
 

·
Registered
Joined
·
6 Posts
Hello everyone,

do you think it is wise to try cleaning EGR if i do not have any problems with my SF except high fuel consumption? Or is it normal for Santa Fe 2,2 CRDi 114kW to use ~11 l / 100 km (50 percent city driving, 50 percent on open roads). Also i am having P1405 trouble, so i think this might have something to do with EGR? But a couple of years ago, we drove to mechanics to check EGR, they said it was fine (it was the first time for P1405 error).
 

·
Registered
Joined
·
26 Posts
@Eimantas -

Unfortunately I don't know enough to answer your question, but for comparison I get low 7L/100km in mine on the open road and about 9L/100KM on 50/50city/road.

Cheers
Skiwi
 
61 - 71 of 71 Posts
Top