Hyundai Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
The four wind screen washer jets all give a squirt of water but only to the bottom of the wind screen! If I put my mouth over the inlet to the washer bottle and blow I would expect to blow water out of the jets, but it does not - I get a "bubbling" sound that appears to come from under the front left hand fender (when facing the vehicle)....sounds like a leak and would explain the lack of pressure from the jets........how does one get to the water bottle? Take the front left wheel off and remove the plastic wheel arch cover????

Thanks David W
 

·
Registered
Joined
·
55 Posts
Hi David, had the same problem on mine & is quite a common fault , had all the wheelarch liner out to get to the workings , try cleaning the filter out this improved mine for a while but eventually lost power again. I have found if you blow into the pipe that leads into the washer bottle this seems to make the spray jets clean for a longer period & get a very powerful spray.
 

·
Registered
Joined
·
48 Posts
had this twice in 4 years, drop the bottle out and clean the little metal mesh filter behind the motor, be full of gunge. may as well do the rear while you are in there.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
Thanks for that. Currently still cleaning and repainting my concrete swimming pool ready for summer....will look at "Terry" after that.

Any "tricks" to make removing the wheel arch covers an easy job......or is there no such thing as as easy job!
 

·
Registered
Joined
·
55 Posts
Hi David, the wheel archliners are an easy job, removing the wheel is best really all the bolts are easily visible, also makes easy access to change the fog/driving light bulbs, envy you a lot having your own pool !!I like to swim every day but have to use the local pool ...
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6
ok pool completed and looking beautiful!
The normal bolts on the liner are ok to remove but the plastic expander bolts are a pain!! One of the filters was badly blocked - cleaned both of them and the water container itself. Liner a Bu......to get back. Thanks for all your tips....
 
1 - 6 of 6 Posts
Top