Hyundai Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
For some time now my dear old i10 has been making a noise similar to a jam jar lid spinning on a desktop. On occasion the sound is almost sleigh-bell like. Very seasonal for later in the year but rather annoying for the attention it draws as I'm driving along. It's rather noisy.

My car is going in tomorrow for this to be fixed. The garage owner and mechanic had the same model i10 as a courtesy car for years so knows the car well. I'm not at all mechanically minded and he says it's the head mounts, so this is what's being done. I think. As none of it really registers with me.

So, before we do this work which may or may not be the issue I thought I'd ask for your ears and opinions to help diagnose the problem. I'll attach a recording below which isn't the best but all I could pick up on my phone. It's a lot louder in the car. It begins as i pull away and continues at speed and is prominent when i turn the steering wheel to the left but is present whatever way I'm going. Sometimes the noise goes away after the car has been used for a period, sometimes not.

The car has done 70000 miles and has been looked after, recently serviced and went through its MOT and nothing of note was picked up when it was being looked at.

Please have a listen and let me have any thoughts.

Car Noise

Thanks for your help and attention.

I don't want to bin this little runaround but may have to if this noise doesn't go away.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #2 ·
Okay, so the car went in. x2 top mount kits fitted plus a couple of belts replaced as a side job. Noise went away for a day then back today and I paid the business end of 300 notes for the work :cry: I've called the garage with a view to rectify but not open again until Monday. Do you think i have a leg to stand on or will be charged again?
 
1 - 2 of 2 Posts
Top