Hyundai Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I was towing a borrowed trailer this weekend which seemed to have damaged my indicators. (Left and right signals) The symptom is:

- that when I turn on the indicators they do not work. No clicking sound of the flasher unit and also now power to the indicators.
- When I press the hazard switch, all 4 indicators illuminate and I can hear the flasher clicking.

I am unable to find any reference in the user manual on how to fault find the indicators. I cannot find a fuse, neither can I find the flasher. Hazard flasher is installed at the hazard switch next to the gear selector.

Please help.
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
17,110 Posts
Sounds like the indicator fuse is blown. Sorry, I'm not familiar with the H1 so I can't tell you exactly where it is but on other Hyundai cars it's usually on the dashboard fusebox, often marked T/SIG (Turn SIGnal). There is usually a list in the maintenance section of the owner manual that tells you what all the fuses are for and where to find them too.

Personally though, when I'm diagnosing a fault, I just test ALL the fuses which is usually quicker than thumbing through the manual. It only takes 5mins to check every fuse on the car if you do it with a voltmeter or test lamp rather than pulling each one and visually inspecting it.

I hope that helps.
Scottie.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top