Hyundai Forums banner

81 - 100 of 101 Posts

·
Registered
Joined
·
3,261 Posts
Because the fuel is under a very low pressure and no atomizing as it sprays. You need to do 2 things. get the fuel pressure right. Specs say 300kPa but I am not sure if thats with or withou the vacuum hose attached to the regulator but aim for that and get the car to spit out codes and live data. A bit of sleep might help to.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #83
Changed fuel pump to other good used pump I bought and a new sock filter. Replaced #6 fuel injector from an 06 2.7 I got from pullapart. Seems to start and idle better. Running with relay in now. Will do fuel pressure test as soon as I can make it to parts store to rent one again. Appreciate the help.
 

·
Registered
Joined
·
3,261 Posts
I had a thought. You have got the gauge connected into the high pressure supply line? If you have made a mistake and have in in the return line and it has a restriction it might explain the very low figures and high fuel consumption. I have found that problem on 2 previous occasions. If there is a blockage in the return line just disconnect it from the regulator and run it onto a large enough container (1 gallon) to allow sufficient time for testing.
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
13,425 Posts
If you have made a mistake and have it in the return line
Now that you mention it, I suspect he has made that mistake. His pressure figures would make much more sense if they were taken on the return. He measured a higher pressure when the engine because there is more fuel returned to the tank when vacuum is applied to the pressure regulator (reduced pressure in the rail = higher pressure in the return).

My guess is he didn't have a flange adaptor to connect the gauge to the fuel supply hose so he just hooked it up the the much more convenient return line. If only it was that simple.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #86
Yes, I had it hooked up to the easy spot. Will do it right next time I rent the pressure tester.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #87
I drive it about 100 miles again today and it seems to act up after I've driven it awhile. Temp gauge is staying where it's supposed to be. Can ecm go eratic when it gets hot?
 

·
Registered
Joined
·
75 Posts
Discussion Starter #88
Also, after changing fuel pump, sock filter, #6 fuel injector, gas mileage is up to around 20 mpg, but still sputters once it's driven for awhile?
 

·
Registered
Joined
·
3,261 Posts
Many faulty electronic components play up when hot but saying that a circuit with a dry solder joint may be just the opposite. Answer yes and no.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #90
Check engine light came on finally, don't know why now? AutoZone shows the following codes: p0102, 0118, 0740, 1529, 0113, 0335, 0227, 0271, 0265. I replaced the following sensors the other day from an 06 2.7 without disconnecting the battery: mass air flow, idle air speed, #6 fuel injector, there another sensor next to idle air speed I replaced not sure of name of it?
 

·
Registered
Joined
·
6,098 Posts
Check engine light came on finally, don't know why now? AutoZone shows the following codes: p0102, 0118, 0740, 1529, 0113, 0335, 0227, 0271, 0265. I replaced the following sensors the other day from an 06 2.7 without disconnecting the battery: mass air flow, idle air speed, #6 fuel injector, there another sensor next to idle air speed I replaced not sure of name of it?
And the results are........drum roll.......?
 

·
Registered
Joined
·
3,261 Posts
Man you gotta be kidding. Have you checked the wiring harness for a corroded connector. The only code that's outside that case is injector current too high.
 

·
Registered
Joined
·
4,250 Posts
Check engine light came on finally, don't know why now? AutoZone shows the following codes: p0102, 0118, 0740, 1529, 0113, 0335, 0227, 0271, 0265. I replaced the following sensors the other day from an 06 2.7 without disconnecting the battery: mass air flow, idle air speed, #6 fuel injector, there another sensor next to idle air speed I replaced not sure of name of it?
Is it possible that all the work you are doing to the vehicle is causing some of the diagnostic trouble codes??
 

·
Registered
Joined
·
75 Posts
Discussion Starter #95
Autozoner ask me if I changed all those parts with battery connected? Said maybe reason for all the codes? Only got 'link error' from 3 different code readers until I started actually being able to drive it this week and I noticed a check engine light was on. Does it sound like ecu on it's way out could be causing this and other issues I'm having? It still cuts out once I've drove it for about 45 minutes. It never has idled right. Stays at about 600 rpms.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #97
Ignition off when I changed them. I went by a auto shop here that Napa auto parts sends work to and get says there's no good way to check fuel pressure on this vehicle the way the high pressure supply line is connected to the fuel rail without damaging it. Any ideas? Also, I bought a engine bay fuse block and ecu from pullapart and will get around to changing those one at a time asap. I remember taking my fuse block loose to try to find a joint connector showing on a 2005 trying to find bad connections and I'm wondering if I've got a wire or connector in there shorting out intermittently?
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
13,425 Posts
says there's no good way to check fuel pressure on this vehicle the way the high pressure supply line is connected to the fuel rail without damaging it. Any ideas?
There is a good way to check fuel pressure on your vehicle. You just need the correct adaptor to fit the Hyundai fuel rail. It's quite expensive for a one off test though...Fuel Rail Pressure Test Adapter Kit
 

·
Registered
Joined
·
75 Posts
Discussion Starter #99
I rented one from AutoZone the other day for a deposit of $150.00 and it had a lot of pieces to it but nothing looked like what your showing me here. This fits 2001 huundai 2.7 I guess? Rental was universal. Maybe I can find one used. Thanks for all your help.
 
81 - 100 of 101 Posts
Top