Hyundai Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi there, I have just brought a 1998 Excel. The fuel pump won't prime up with the ignition turned on, have hooked up the pump directly to 12 volts and it's pressurising the system ok. Where is the fuel pump relay located as it's not in the fuse/relay box under the bonnet, I've located another set of relays RH side of the steering column which has a yellow relay for the heater fan and one is the flasher unit, there are 3 others there as well. PLEASE HELP SOMEBODY, ANYBODY
 

·
Registered
Joined
·
2 Posts
Hi Kev I am in exactly the same position, its very frustrating as my engine will run for about ten minutes, looks like I will have to take it into a local mechanic Tuesday, will let you know the outcome. Regards neil.
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
13,405 Posts
Hi Neil.

I think Kev is long gone. Only two posts back in 2014.

FWIW, your symptoms sound like a crank position sensor failure. Can you restart the engine immediately after it cuts out, or do you need to wait for the engine to cool down a bit before it will start again? Often the sensor will stop working when it gets hot then work again when it cools down a bit. I don't know what type of sensor is used on the Mitsubishi engines but it's quite a common fault on the later Hyundai engines anyway.

When it wont start, have you checked to see if there is spark at the plugs and that the fuel pump is running...DURING CRANK?
 
1 - 3 of 3 Posts
Top