Hyundai Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
hi everyone my car is the i30 SR 2litre petrol. the front windscreen wipers work ok, the washers have stopped working.
the handbook does not give any info. about the washer motor location, its removal, or the fuse concerned.
the rear wipers & washers are operating ok. has anybody got any knowhow on this problem ? :innocent:
 

·
Registered
Joined
·
425 Posts
My rear wash function failed last year although the wiper was fine. Front wash/wipe was also fine.

Rear wash+wipe share the same fuse so not a fuse problem.

I would say your pump has gone. There's just the one pump unit servicing both front & rear and its mounted on the base of the washer bottle, nicely out of sight.

I had my pump replaced under warranty. Suggest you call your dealership.

HTH
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
on my car the rear washer. motor is inside the liftup hatch
accessed by just removing a small lift off panel, in the middle, just below the rear windscreen. :innocent:
 

·
Registered
Joined
·
425 Posts
QUOTE (ackerbill @ May 2 2010, 07:23 AM) index.php?act=findpost&pid=318727
on my car the rear washer. motor is inside the liftup hatch
accessed by just removing a small lift off panel, in the middle, just below the rear windscreen.
Hmm in which case my apologies for misleading you. The washer installation must have changed dramatically since my '08 build.

Stll a warranty visit though, so you're covered.

Don't suppose, for interests sake, you could post a wee picture of the inside of the hatch, with the lift off panel "lifted off"?
 
1 - 4 of 4 Posts
Top