Hyundai Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
106 Posts
Discussion Starter · #1 ·
After I replaced the front struts, I could hear a rattle in the front end. It was related to hitting bumps as opposed to engine/drive speed. Looking underneath (while changing out CV half axles) I could see this:
wSubframe Loose (4).JPG

A closer look:
wSubframe Loose (3).JPG

And slightly different angle:
wSubframe Loose (2).JPG

This one bolt is loose but I could not get it to tighten up any. The hole next to it is where, apparently, another bolt is completely gone. Anyone know anything about subframes or possibly what sizes/grades these bolts are? Any theories as to why or how this has happened to the car?

I suspect this is the cause of my rattle, but I'm unsure how to actually prove that to myself. Regardless, this obviously needs to be fixed.
 

·
Registered
Joined
·
3 Posts
Looks like your missing parts 62469 and 54839B (see attached image). Looks like you hit something and it knocked the bolt off. See the rusted scratches in the paint leading to where the bolt should be. I bet you will need to extract the rest of the broken bolt out of the hole. Look at the other side of the car. Should be mirror image of what it should look like. Good luck.
 

Attachments

·
Registered
Joined
·
106 Posts
Discussion Starter · #3 ·
This is odd

Actually, the one bolt that is hanging partially out has a bent washer under it. The bolt that is missing is a clean hole. It's almost like someone took this apart and didn't get the first bolt seated and lost the second one.

But I really appreciate the diagram. That is most certainly useful. And, yes, I realized the other side is the mirror opposite, which helped me to see which hole was empty and needed a bolt.

I'm not sure I can extract the bolt that is hanging down. I know I certainly cannot drive it further up, even with my pnuematic impact wrench.
 
1 - 3 of 3 Posts
Top