Hyundai Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi
I have a 1999 Hyundai Galloper fitted with a 2.5TD D4BH engine with intercooler .
I can drive for a while and every time I stop the idle speed is perfect.
Then I can stop again and the idle speed suddenly is high.
I have checked the vacuum hoses and can’t find any splits or damage.
Any help would be very grateful.
 

·
Registered
Joined
·
5,241 Posts
Do you have a scan tool that can show live data? Would be nice to look at a few things when this happens.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
Thanks for your fast reply.
I haven't got a scan tool.
Is that the device that plugs into the ecu???
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
Hi
I bought a Foxwell NT520 pro only to find that the DLC connector on the device is a 16 pin and mine is a 12 spade connector type with only 6 of them in use.
Contacted Foxwell and they only have the 16 pin connector.
Before I send it back any ideas on how I could convert the connector would be appreciated.
 

·
Registered
Joined
·
12,165 Posts
Before I send it back any ideas on how I could convert the connector would be appreciated.
Search ebay and I'm sure you'll find an adapter to convert the 16pin OBD2 connector of the tool to Mitsubishi 12pin OBD1.

Or I'm sure I'll have a pinout for the 12pin connector somewhere if you want to make your own.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #9
Ok. I bought the adaptor. Plugged it in, turned ignition on and the Foxwell device didnt boot up. Dead as a door nail. Lol.
When I plugged it into my computer it booted up.
Any suggestions please.
 
1 - 9 of 9 Posts
Top