Hyundai Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
111 Posts
Discussion Starter #1
Well, I had my E in for service today to get her fluids changed and to replace her engine oil with Synthetic finally (second service for her).

I had noticed a rattle in the undercarriage for a few weeks now and assumed it was a common TSB for a heat shield that rattles. As it turns out, it is the resonator pipe that needs to be replaced (under warranty). I've never had to replace one before so hopefully it's just a one-off!

Otherwise, I can already tell she's happy to be filled with some wonderful Synthetic ;)
 

·
senior member
Joined
·
22,788 Posts
Well, I had my E in for service today to get her fluids changed...
I hope you meant "checked" and not "changed" when referring to the fluids. Shouldn't have been a need to have any fluids changed...well, except for the oil, which you did have done. That's probably what you meant. I was just reading your post and the words "fluids changed" set off the alarm on my "Sneaky Dealer" radar unit. :wink2:
 

·
Registered
Joined
·
111 Posts
Discussion Starter #4
Yeah, just the Oil Rich ;) I think they might have topped up the washer fluid too.

Then they gave me a hard time about my hubcaps on my winder rims. They don't line up exactly with the valve stems (rims were from a Mazda 3) so the valve stems sorta get pushed out of the way.

The tech thought that it might cause them to get sliced by the hubcaps. I don't see how though. The wheel bolts hold the hubcap in place so it's not like it has any way of spinning at all. They probably though I had some cheaper push on caps that 'could' rotate separate from the tire and thus 'could' cause an issue. Guess we'll see who's wrong!
 
1 - 4 of 4 Posts
Top