Hyundai Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I've inherited a Hyundai terracan limited edition 2.9 from a relative. As it has been sat unused for a number of months, the battery was dead.

I charged the battery for a good 6 hours or so today and according to the charger it was full and done.

I took for a spin and all was well, stopped to get petrol for a few minutes. Go to start engine, nothing. I can hear it trying but just nothing. Had to get a friend to turn up to give it a jump start. Was fine and I went for another spin for around 30 mins.

Got home and turned engine off and just out of interest, tried engine again - won't start. I would have assumed my 30 min spin, and the fact it had a full charge earlier today it would at least have started literally a second aftet turning the engine off.

Is this a case of the battery was that dead as it had been out of use for months therefore simply still hasnt been fully charged? Or does it sound like I require a new battery?

I wil be charging it again tomorrow, do I leave it charging for a few hours extra even once the charger claims it is fully charged?

Thanks
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
You need to test it after you charge it up. Do you have a multimeter?
I don't no. Like Drunken Elvis says (😂) would it be easiest all round yo just get a new battery?

I'm always up for the best and quickest solution rather than messing about trying this and that.
 
1 - 4 of 4 Posts
Top