Hyundai Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
Hey guys, been having a problem with the engine taking longer than usual to start. Instead of starting right up when you press the start button it tries to crank for about 3 or 4 seconds before finally starting. I have not noticed a pattern of when it does it or what causes this but its been going on for maybe 8 months to a year. Sometimes it cranks fine, sometimes this happens. Not throwing any codes, vehicle has 55k miles and the 2.4. I took it to the dealership for the second time about this yesterday and they said they finally got it to replicate my starting issue and replaced the high pressure fuel pump. I had a suspicion it was this based on what i had researched on the forums...but heres the problem...after getting the vehicle back and having the HPFP replaced I am still having the same issue. Anyone else running into this problem? Im guessing it has to be either something fuel delivery or ignition based. It kinda seems like the fuel rail isnt primed or something. Starter seems to be operating fine and we replaced the battery when this issue first started so Im ruling both of those out. Ill be taking it back to the dealership soon, I just need this problem sorted out, this is our primary travel vehicle.
 

·
Registered
Joined
·
1,179 Posts
Would of said battery and the HP fuel pump, but you mentioned both. Have the battery checked and scan for codes again. Possibly a range switch issue??? I just replaced mine, but not for your symptoms. Cheap and easy, though. $30 part.
 

·
Registered
Joined
·
427 Posts
I had the same issue happen 4-5 times in 2 years.
happens when fuel is, or was, kept low.
dealership said maybe condensation in gas

I fixed it with a can of water remover for gas lines, never happened again. Plus, I don't let the fuel get below 1/4 during winter now.
was it just that, I don't know.
STP All Season Water Remover | Canadian Tire
 

·
Registered
Joined
·
44 Posts
Discussion Starter #4
I had the same issue happen 4-5 times in 2 years.
happens when fuel is, or was, kept low.
dealership said maybe condensation in gas

I fixed it with a can of water remover for gas lines, never happened again. Plus, I don't let the fuel get below 1/4 during winter now.
was it just that, I don't know.
STP All Season Water Remover | Canadian Tire
At this point ill give it a try. We never let the fuel drop past a quarter of a tank though. last week was the first time in the two years of owning the vehicle that we actually did let it go below a quarter of a tank. I didn't notice it acting any worse that it usually does during that time.
 

·
Registered
Joined
·
427 Posts
Bah, you have nothing to loose, it's less than 10$, and mine never did it again after that bottle... I don't know if it's related or not.
 
1 - 5 of 5 Posts
Top