Hyundai Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi I've got a Hyundai Getz 03, runs ok when I go on long journeys, if I go on short 5 to 10 minute runs stop, try to start it again it will start but I can not rev the engine or go anywhere it is just ticking over, turn Car off leave it about 20 Minutes and it starts ok. I've taken it back to the main dealers & they do not know what is, serviced it & put it on a engine cleaning system & still the same, by the way it's a diesel 1.3. Can anyone help me with this problem as I can not make short journeys without thinking this is going to happen all the time .
 

·
Registered
Joined
·
548 Posts
hmm...since it is a diesel, did you look at the fuel lines in general...pinhole leaks or seeping of fuel on ends of fittings? I don't know much about the Getz at all because the states don't sell them, but strictly from mechanical experience. Smell the oil in the crankcase as well or dipstick looking for the odor of fuel also -this may show an internal leak. Diesels hate air in their fuel lines.

This car has no runnability issues otherwise? No revving on it's own or intermittent high idling?

Good luck
 

·
Registered
Joined
·
548 Posts
no, since you have no other symptoms. I find it odd dealer didn't find anything.

Have you scanned car for trouble codes? Even if there is no "check engine" light on there still may be codes stored in the system.

Also, another idea may be to take one of the techs for a ride and produce the symptoms for yourself.... especially if it is a frequent condition, it should be fairly easy to reproduce. Make sense?
 

·
Registered
Joined
·
3,151 Posts
since this problem is easy to reproduce....get it to do this again. then try disconnecting battery cable for say 1 minute. reconnect. simple test for bad electronics. exactly what we can narrow down next.

just stop with the engine cleaning nonsense. that does not fix problems, it creates them.
 
1 - 5 of 5 Posts
Top