Hyundai Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hello!

now that my hyundai is working i still have a problem that i was affraid its was going to remain from the previous owner, and that is the sound from the piston bearings/crankshaft bearings
now the engine idles normaly very very nice, no sounds nothing, but when you pressit to araund 1800 rpm, it starts making a strange noise, the oil pressure light does not come on ever.
ive put in new oil and filter and let it idle for abaut an hour, the noise calmed down in higher rpms, but is still there.


what do you suggest, should i replace only the bearings or the shaft also.

CHEARS
 

·
Registered
Joined
·
146 Posts
Should only need bearings, but there are never guarantees until all the parts can be inspected. In cases where it is bad enough, like when grit or metal in the oil has cut up the crankshaft journals as well as the bearings, the crank can be ground to remove the imperfections and oversize (or I guess undersized, in this case) bearings can be used to make up the difference.

Either way, you can't know how bad things are until you can see it.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
today i have removed the lower oil pan cover, now the upper one is posing a problem, is it necessary to remove any thing more than the starter and exhaust hose ( and all the pan bolts). because the oil pan wont budge, any ideas?

chears
 

·
Registered
Joined
·
220 Posts
Guess I could have help here, the lower oil pan is not nessesary to be removed. Its just there to protect the engine if you run over something that will crack if it was all alluminum.

I hope what your describing isn't the same issue I have with my old engine, too much sludge buildup from oil change neglect which cause a quiet idle but loud at 2k+ rpm. In my case the engine was trash from top to bottom and eventually the car would die and the Oil light would come on.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
The bearings have been replaced, ive put in 5w40 full syntetic oil and it seem like its running ok, there is a 0,1 mm diferenje between the first and second bearing journal, i hope it will last :banana:

with regards
 

Attachments

1 - 5 of 5 Posts
Top