Hyundai Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
i have owned a 2007 Hyundai Santa Fe 2.7 fwd for about two years now. throughout this time i would sometimes have a problem where it would seem like a fuse blew. out of no where i would lose power to the cigarette lighter, blower motor, glove compartment and my Bluetooth that was plugged in. some times it would all come back on by itself, but sometimes i would have to open the glove box or even slam it for it to come back on at all, well, last night i jump in the car. start it. and then boom. it does it again. i follow my typical routine and give it a few slaps and slams as usual. yet nothing. so i drive to my destination without heat. i get there and try working a little bit then all of the sudden it works. the blower ,accessories, cigarette lighter, and all. meanwhile the radio was giving off this annoying beeping tone/ sound. that i have never heard before. i thought it was my phone because the Bluetooth so i disconnected my phone from Bluetooth but it was still beeping at me. i turned the radio up it got louder. if i turned it down it got quiet. then i opened the glove box. the light inside was very very dim. i went to close the glove compartment and reopen it and the light cam dim and then everything went off again. first i thought i was the blower motor. i removed the cover from under the glove. i have not removed the blower motor yet.i checked the cabin air filter. i replaced it. it was very dirty. however. is there a fuse i should look at first before replacing the blower motor? is it common for the glove compartment, the blower motor, cigarette lighter and accessories to all go out? any help. thanks.
 

·
Registered
Joined
·
63 Posts
i have owned a 2007 Hyundai Santa Fe 2.7 fwd for about two years now. throughout this time i would sometimes have a problem where it would seem like a fuse blew. out of no where i would lose power to the cigarette lighter, blower motor, glove compartment and my Bluetooth that was plugged in. some times it would all come back on by itself, but sometimes i would have to open the glove box or even slam it for it to come back on at all, well, last night i jump in the car. start it. and then boom. it does it again. i follow my typical routine and give it a few slaps and slams as usual. yet nothing. so i drive to my destination without heat. i get there and try working a little bit then all of the sudden it works. the blower ,accessories, cigarette lighter, and all. meanwhile the radio was giving off this annoying beeping tone/ sound. that i have never heard before. i thought it was my phone because the Bluetooth so i disconnected my phone from Bluetooth but it was still beeping at me. i turned the radio up it got louder. if i turned it down it got quiet. then i opened the glove box. the light inside was very very dim. i went to close the glove compartment and reopen it and the light cam dim and then everything went off again. first i thought i was the blower motor. i removed the cover from under the glove. i have not removed the blower motor yet.i checked the cabin air filter. i replaced it. it was very dirty. however. is there a fuse i should look at first before replacing the blower motor? is it common for the glove compartment, the blower motor, cigarette lighter and accessories to all go out? any help. thanks.
All 2007's have bad grounds. Check them all especially the neg battery cable to fender connection.
 

·
Registered
Joined
·
6,091 Posts
Go through all the grounds. Don't just look at them. Remove the cables, clean and re-install. Pay particular attention to the engine firewall ground strap.
 

·
Registered
Joined
·
378 Posts
Yes check all grounds & threaded holes for any corossion or green residue where the bolt screws in to the actual hole itself for ground there could be corossion in there clean it out using a threaded tap
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
13,422 Posts
Personally, I wouldn't waste my time checking grounds out in the engine bay. I can't think why slamming the glovebox would effect a ground out there. Plus, if one of the main grounds in the engine bay was bad you'd be having problems with more circuits than the few you mention. It sounds to me more like there is a loose connection in the area of the glovebox. That's where I would be focusing my efforts, not in the engine bay.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #8
i notice now that all those things turn off when i have my headlights on. if i turn off my headlights , the glove light and accessories comes on very dim but the blower motor does not. but if i turn on my headlights everything goes off again.?? so weird. ill check grounds. but at this moment this is the only electrical issue im having.
 
1 - 8 of 8 Posts
Top