Hyundai Forums banner

1 - 20 of 28 Posts

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
15,589 Posts
If your replacing the ECU you'll need one with the same part number as your original ECU. But why are you replacing it?

Also, it would be helpful if you would take the time to fill in your forum user profile with the details of your car and it's engine. We don't even know what engine is fitted to an Egyptian Accent at this point.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #6
The problem is my car was manual the i transformed it to auto i cant confirm.the ecu part number
The main problem that i had an error p1560 which is related to knock sensor
My engine is 1.6 alpha cvvt
I already replaced the knock senor but the problem still exist
Why i suspect the ecu
Cause i reflash cause it has fuel pressure sensor which my car isnt equiped with
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
15,589 Posts
AFAIK, none of the Alpha engines have fuel pressure sensors. They have MPi fuel systems. Only GDi & CRDi engines have fuel pressure sensors.

Have you checked the wiring between the knock sensor harness connector and the engine PCM?
 

·
Registered
Joined
·
44 Posts
Discussion Starter #9
i had check the harness but no problem exists
anyone have the software for PCM with maf sensor
cause i found alot only with map sensor automatic transmission
 

·
Registered
Joined
·
882 Posts
Ask your local Hyundai dealer, type in your VIN and they can tell you the part number of your ECU. Pull out an used ECU with the same part number from junk yard, swap ECU and ready to go. No need to program
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
15,589 Posts
Ask your local Hyundai dealer, type in your VIN and they can tell you the part number of your ECU.
Actually, they wont. They will give him the part number of the original manual transmission ECU since that was what was fitted when the car left the Hyundai factory.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #12
i found ecu which already , i tried for about half hour
but i found that he has no feedback from Knock sensor
while the was running normal,in which i cant understand how
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
15,589 Posts
So you've replaced your original manual transmission engine ECU with an engine ECU from a car with auto transmission?
Did you also fit the engine wiring harness from the auto transmission car? Sometimes there are differences between the wiring of the two ECUs.

What is your engine code....G4xx?
 

·
Registered
Joined
·
44 Posts
Discussion Starter #15
i replaced the chip and the Ecu is working fine
Except i still had small problem
My car has a hood harness for abs but not equipped with abs System
while i had only vss sensor send to the internal cluster the car also is not equipped with wss
so the problem is that the PCM cant read the vehicle speed
i already compared another car the same configuration
if any one can help
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
15,589 Posts
if any one can help
You could try linking the output of the VSS to the ABS speed signal wire. I think it's electrically the same type of signal although I doubt the signal frequencies are the same. Still, that might at least get rid of the P0501 trouble code which I assume is being logged.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #19
yes i already tried with a lot of caution to avoid damage the signal sent to the EPS
now the PCM read the vss signal but very low it gives 1 km/h while i was at 30
but the cluster was working fine
any one can help adjusting
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
15,589 Posts
any one can help adjusting
You'd need a frequency multiplier circuit to increase the VSS signal frequency. There are dedicated ICs for that purpose but I used an arduino micro controller for a similar project just because I had one to hand. You can adjust the input : output ratio in software if using the arduino which makes adjustment really easy.

I made a couple of posts about my arduino signal modifier on my cruise control thread....link below. Unfortunately I've removed the demo videos that showed the circuit working.

Cruising With Arduino
 
1 - 20 of 28 Posts
Top