Hyundai Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi, new here so please bare with me.
I have a 1999 H100 which I use for transporting my motorcycle along with as a day van and I love it.
However, just recently I have had the water trap (?), Battery charge, Handbrake on and Oil level warning lights all stay on when the van is running- Until today it's not been a problem (other than annoying) but today the battery had very little charge and I needed to get a jump start.
Has anyone please got any ideas for what might be the issue and where I should start looking please?
 

·
Registered
Joined
·
622 Posts
Hi, new here so please bare with me.
I have a 1999 H100 which I use for transporting my motorcycle along with as a day van and I love it.
However, just recently I have had the water trap (?), Battery charge, Handbrake on and Oil level warning lights all stay on when the van is running- Until today it's not been a problem (other than annoying) but today the battery had very little charge and I needed to get a jump start.
Has anyone please got any ideas for what might be the issue and where I should start looking please?
Sounds like the alternator has crapped out.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Cheers, am just about to test that but it still doesn't explain why the other lights in addition to the Battery Charge light are being lit unless there is some reason for it due to the charge being all over the place (limited charge getting through perhaps?)
 

·
Registered
Joined
·
622 Posts
Cheers, am just about to test that but it still doesn't explain why the other lights in addition to the Battery Charge light are being lit unless there is some reason for it due to the charge being all over the place (limited charge getting through perhaps?)
Those lights always appear when the charging system is inop. That's the main reason I know the alt is done. It could also be the alt ground too, which would do the same thing, causing the alt not to work. Not sure what vehicle you have, but see if the big alt fuse is good too.
 

·
Registered
Joined
·
1 Posts
Warning lights

Hi, new here so please bare with me.
I have a 1999 H100 which I use for transporting my motorcycle along with as a day van and I love it.
However, just recently I have had the water trap (?), Battery charge, Handbrake on and Oil level warning lights all stay on when the van is running- Until today it's not been a problem (other than annoying) but today the battery had very little charge and I needed to get a jump start.
Has anyone please got any ideas for what might be the issue and where I should start looking please?
Hi, I'm having the same problem. How did you resolve yours?
 

·
Registered
Joined
·
103 Posts
I was about to say when warning lights start to come on, First thing is Probably the Alternator. Now you say vehicle battery R/s, this confirms it was not charging, Diesels always give a warning like this, including Heavy Trucks. This normally happens before the battery/ alternator light come on.
 
1 - 7 of 7 Posts
Top