Hyundai Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
:mad:
Hi, I'm new to posting threads so hope it works. Can anyone tell me where the crankshaft position sensor is on the 2.0 CRDi diesel engine.
Regards
Ade.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3

·
Registered
Joined
·
1 Posts
Crankshaft position sensor crdi 2.0ltr

I have been trying to find info on the crankshaft position sensor on a crdi 2.0 diesel for nearly a week and still couldn't come up with an exact location... This is a European model in Ireland - not sure if there's a difference in models. This is what I did to get at it.

If you stand in front of the car... on the right hand side of the engine block in the gap between the air filter box and the engine there is a cluster of cables.. There are two cables clipped onto the side of the engine with connector blocks on them. The top one is the three way connector for the crankshaft sensor cable.
Both cables run around the back of the engine. If you lift the inter cooler and the plastic engine cover, remove the air filter box lit and filter and push the plastic air feed back to the fire wall of the car it is possible to reach the sensor around the back. It takes a little bit of messing but it can be removed and replaced from there.

The fault I was experience was the car would start one day and then the next day it wouldn't - if I left it an hour it could start. When I wasn't experience the fault I disconnected the camshaft sensor and the car started - contrary to what I had read on forums - this indicated that it wasn't the camshaft sensor. Finally the car just wouldn't start and I've just replaced the crankshaft sensor and it started perfectly.

Hope that helps someone
 

·
Registered
Joined
·
1 Posts
Hello and thanks for the post Tearaway.
I have a similar problem, sometimes hard to start when hot.
Ordered a crank sensor online (not original part) and replaced it.
Got alot of other issues, hesitation, stops.
Finally i put the old cranksensor back and it runs much better, but it still hesitates and stops sometimes.
And still wont start if i leave it for 10 minutes when its hot. (need to wait 30 minutes Before it starts again)
I still Think the old crank sensor isnt 100% ok so ive ordered another.
Will post my progress, if any
Woody
 
1 - 6 of 6 Posts
Top