Hyundai Forums banner

1 - 20 of 73 Posts

·
Registered
Joined
·
146 Posts
Discussion Starter #1
My '18 Value Edition with about 8,000 miles is experiencing an occasional creaking sound, more so when on uneven pavement. Anyone else experience this?

Thanks in advance,
Ryan
 

·
Registered
Joined
·
122 Posts
My 2018 VE is doing what sounds like it may be the same thing or something similar. Took it to the dealer, they couldn't replicate the problem and couldn't figure it out. I'd take yours in and have them at least put it on record even if they can't figure it out.
 

·
Registered
Joined
·
50 Posts
My car has been doing this since 9000mi. Been to the dealer 4 times, duplicated the concern but they don't know how to fix it. 25000mi on the car and the noise is still there. I just ignore it.
 

·
Registered
Joined
·
17 Posts
The issue is your engine mount brackets. They are bad and need to be replaced. Had the same issue with mine, and after months of trying to figure out what it was, replacing the engine mounts fixed the noise.
 

·
Registered
Joined
·
146 Posts
Discussion Starter #8
Has there been a recall on the engine mount brackets? Is there any telltale sign that they are bad? Or will it have to replicated first in a test drive in order for the dealer to replace?

Thanks again,
Ryan
 

·
Registered
Joined
·
17 Posts
I don’t think there is a recall. The dealer had mine for 3 weeks and couldn’t figure out the issue. They called the Hyundai tech line and were advised to replace the engine mount brackets. I guess Hyundai is aware of the issue.
 

·
Registered
2019 Elantra GT N-Line 2018 Elantra GT Sport
Joined
·
241 Posts
Considering how often I read about this issue, both on '17s and even '18s, I wouldn't be surprised if they are preparing to issue a recall on these.
 

·
Registered
Joined
·
1 Posts
My 18 SE also does this. I took it in to the dealer twice, of course they didn't hear it, so I had to be persistent. On the 3rd try, they replaced the "upper engine mount" supposedly, and said they test drove it and didn't hear anything. It took me less than 20 miles to notice it again. Guess I'm gonna keep wasting my time coming back. This was my first "new" car, and I thought I was buying peace of mind. Also, the dash since the first week I got it has made a creaking sound when accelerating sometimes, then it would stop for a while, then happen again. Brought it to the dealer with 3k miles and the guy said to give it a few miles to "settle in", like literally no problem I've ever had solved itself. These guys are just trying to get me to ignore the problem until my warranty is up
 

·
Registered
Joined
·
57 Posts
I called several dealers to attempt to see if this is a common issue.. and that they actually have a fix... none of the dealers are aware of any issues... when turning right... suspension noise

if anyone has got this fixed, please post invoice on what they actually did, Tech info... TSB... etc

Have a great day
 

·
Registered
Joined
·
17 Posts
I called several dealers to attempt to see if this is a common issue.. and that they actually have a fix... none of the dealers are aware of any issues... when turning right... suspension noise

if anyone has got this fixed, please post invoice on what they actually did, Tech info... TSB... etc

Have a great day
I’ll post my invoice once I’m back with my car. My car is in another state right now and not sure when I’ll be back to get it.
 

·
Registered
Joined
·
3,571 Posts
Hate this time of year, use to have clean snow, putting that salted brown or black crap in it, fender wells are load with it, and yes, creaks, and groans. Crap is in the coil springs, no use going to the car wash, will be a mess when I get home. Talk about a huge mess, my garage floor.
 

·
Registered
Joined
·
11 Posts
I changed my 2017 by 2018 limited and the difference with the panoramic roof is more intense. the truck weighs 400 pounds more and is harder. he did not change suspention so much and I think it will look long term: /
 

·
Registered
Joined
·
14 Posts
Mine also does this, took it to a dealer and they laughed and said it was something in my glove box.

So, I took it to a different dealer and they said it was the strut tower bolts, they changed them...

Still does it! Going back to the dealer on March 2nd to get this problem fixed. ONLY when making right turns and going over bumps!
 
1 - 20 of 73 Posts
Top