Hyundai Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Hello,
This for an Accent GLS 2008
For two months, I've had problems with slow cranking of the engine( like the engine would crank longer than usual, then start). This was progressing worse and worse (taking more and more time to start). and sometimes it wouldn't even start from the first time. So I thought it was something to do with the battery. On the day I decide to pick up a new battery, the car wouldn't start (it would just keep on cranking without starting). so I had to jump-start it (Only worked car to car). After I got my car to start, I drove to advanced auto parts to pick up my new battery. the guy tested my old battery and on the reader and it said: "good, needs to be recharged". I changed my battery anyway, and started the car ( it started like a charm) and drove home. After two days I come to drive my car, and it gave me the same problem, it would crank and crank but never start. So I had to jumpstart it again, I drove it to back to advanced auto parts to do a Battery, Alternator, and Starter test and all was good. I thought maybe I have dirty gas in my car or water. So I decided to buy Gum out fuel system cleaner. I drove for some time and parked it. I started it after like 5 hours, and it worked. However, after 2 days I came to start it the same problem occurred. Cranks but never starts. ( I have a feeling when I don't use my car within one day this happens).


Do I need new spark plugs maybe?
 

·
Registered
Joined
·
2,866 Posts
The fact that it starts with a jump start is telling you something. Try cleaning all the main earths and battery terminals. Have you had the car scanned. A common no start is the crank sensor but your telling me it starts with a jump should eliminate that.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
I will clean the battery terminals.
I also purchased a brand new battery but will clean terminals.

could it be that I need spark plugs?

The person working at Advanced Auto Parts refused to scan for codes since I do not have a check engine light on. (even though I know that pending codes could possibly show on the reader).
 
1 - 13 of 13 Posts
Top