Hyundai Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have an 07 entourage, and the cooling fans do not work. I wired both directly to the battery and they came on. I have read references about checking the relay but now where on my diagrams do I see a label for the relay, not sure which one it is. The engine does not seem to get much hotter, but the AC only cools when moving, not at idle.
 

·
Registered
2007 Honda CRV
Joined
·
4,414 Posts
Don't know the schematics that you are using
However, it should show a box and inside is a coil and a switch.
When the coil is energized, the switch either closes or opens (most close)
If it closes when energized then the switch is drawn as open
Also, usually drawn with power at top (fuse) and drawn down to relay and then load and ground

When the AC is turned on, both fans should be turned on.
If both fans work then it could be the relays or the control to the relays or the wiring

Hope this helps.
 

·
Premium Member
Joined
·
875 Posts
I have an 07 entourage, and the cooling fans do not work. I wired both directly to the battery and they came on. I have read references about checking the relay but now where on my diagrams do I see a label for the relay, not sure which one it is. The engine does not seem to get much hotter, but the AC only cools when moving, not at idle.
Cooling Fan Relay location attached.
 

Attachments

·
Registered
Joined
·
1 Posts
Find someone who can help you with fixing your fansIf you knew someone then try to approach them, with would be much easier for you to fix your fan.
 

·
Registered
Joined
·
16 Posts
I had the same problem with my Santa Fe, I had bought non-OEM replacement relays, but it only seemed to help some of the time. I finally replaced every relay with OEM Hyndai brand only, and had a number problems clear up, including fans working perfect.
 

·
Registered
Joined
·
16 Posts
Just FYI I had to hunt for reasonable priced OEM relays and food best deals on eBay, some on Amazon, and Ali Express. I took weeks and multiple searches, so keep trying
 

·
Registered
Joined
·
1 Posts
I have an 07 entourage, and the cooling fans do not work. I wired both directly to the battery and they came on. I have read references about checking the relay but now where on my diagrams do I see a label for the relay, not sure which one it is. The engine does not seem to get much hotter, but the AC only cools when moving, not at idle.
Blue box behind fuse box green and yellow wires. Splice green one put switch in-between green wife.
 
1 - 15 of 15 Posts
Top