Hyundai Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
hello all. I have a 2010 santa fe limited v6 fwd that is experiencing clunking/rattling on the driver front side. Originally thought it was the tie rods so i replaced them as they had a lot of play, this didn't fix it. Now I'm starting to think its the lower control arm/ball joints. My vehicle has just over 150k and i am assuming they are original.

The clunking/rattling seems to be more prevalent at lower speeds over bumps, etc.

any insight would be helpful for this newbie.

Also, anybody have the service manual they could send me? I would really appreciate it.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
sway bar end link, ball joint and strut condition ....... But start with end link first.
So i ended up changing out the struts with the monroe quick struts and also new stabliizer links and the knocking on the left where i had the issue went away. No for some reason i have knocking on the right. Could it be a defective quick strut? I didn't have knocking before and no i do?

thanks
 

·
Registered
Joined
·
95 Posts
It could be that you never got the sway-bar end link tight enough when you attached it to the new strut. It's easy to think they are tight, but the ball may be spinning inside the end link. Give a good yank on that end link to see if you hear any clicking.

I'd say it's very unlikely you have a defective new strut, but anything's possible.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
It could be that you never got the sway-bar end link tight enough when you attached it to the new strut. It's easy to think they are tight, but the ball may be spinning inside the end link. Give a good yank on that end link to see if you hear any clicking.

I'd say it's very unlikely you have a defective new strut, but anything's possible.
thanks for the reply. Im also wondering if the stabilizer link is defective. I bought the economy mevotech from rockauto.

I thought i was in the clear and was a happy newbie with my accomplishments. Now im frustrated again...
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 ·
thanks for the reply. Im also wondering if the stabilizer link is defective. I bought the economy mevotech from rockauto.

I thought i was in the clear and was a happy newbie with my accomplishments. Now im frustrated again...
well i just went a took a look at it again and i think i know part of the problem. I think i tightened the bolts on the bearing plate to much and stripped one of them. I think it stripped away from the actual bearing plate. I am assuming this is whats causing the knock since only 2/3 bolts are making contact with frame of the vehicle. I need to get home from work today ~35 miles, you think its ok to drive with only 2 bolts attached to bearing plate?
 

·
Banned
Joined
·
6,990 Posts
Are you referring to the control arm calling it bearing plate?
 

·
Banned
Joined
·
6,990 Posts
Im actually referring to the top plate of the strut/suspension that connects to the car via 3 bolts.
I'm sure I could have figured that if I took the time to read the entire post but you could have been in an accident in the time that could take me. LOL
Drive carefully and repair it soon. Watch out for pot holes. :)
 

·
Registered
Joined
·
3 Posts
Did you check the sway bar bushings? I've found that about 85% of the time or more that's where clunking up front comes from. They may seem tight, but with 150k on it I'll bet they are shot.
 
1 - 11 of 11 Posts
Top