Hyundai Forums banner

21 - 34 of 34 Posts

·
Registered
Joined
·
5,513 Posts
I removed the 4 screws and 2 bolts from the housing (step 4, glove box3.pdf). It still feels like the housing is attached somehow on both ends. I've removed the cabin air filter tray, and it still feels like there are more attachments (more screws, bolts, or clips etc) on both left and right edges. There is also a on/off button (not sure what this does yet) on the left side of the housing I disconnected.
Did you reset the HVAC module?
 

·
Registered
Joined
·
5,513 Posts
Yes, exactly. I hear the Air Blend Door actuator needs to be replaced. So I need to access the actuator behind the floor duct, which is behind the glove box housing.
Try a reset first. Only takes a couple minutes. Many times the system loses it's memory and needs to be reset and relearn. The module learns the full open and full close positions of the doors.

Pull the fuse for the HVAC....turn the controls to full cold.....put fuse back in (needs to be out for a full minute) and turn the key to run position....do not start....allow the system to go through the relearn process....do not touch any controls....you'll hear it working the doors (takes less than a minute)....when finished start the car and see what you get...
 

·
Registered
Joined
·
7 Posts
Try a reset first. Only takes a couple minutes. Many times the system loses it's memory and needs to be reset and relearn. The module learns the full open and full close positions of the doors.

Pull the fuse for the HVAC....turn the controls to full cold.....put fuse back in (needs to be out for a full minute) and turn the key to run position....do not start....allow the system to go through the relearn process....do not touch any controls....you'll hear it working the doors (takes less than a minute)....when finished start the car and see what you get...
I tried to reset the HVAC by pulling the fuse. I tried this a couple of times. Hot air still blows from the passenger side while AC blows cold on the driver side.
 

·
Registered
Joined
·
5,513 Posts
I tried to reset the HVAC by pulling the fuse. I tried this a couple of times. Hot air still blows from the passenger side while AC blows cold on the driver side.
Could you hear it opening and closing the doors? If so, it went through the learning process and that door actuator needs to be checked.
 

·
Registered
Joined
·
7 Posts
Could you hear it opening and closing the doors? If so, it went through the learning process and that door actuator needs to be checked.
Yup, tried it again today and heard the doors opening/closing. Still blows hot on the passenger side only. I suspect the actuator is bad. Now I just need to get passed that glove box housing to remove the floor duct so I can get at the actuator behind it.
 

·
Registered
Joined
·
1 Posts
Climate Control Issues, No Heat to Front Vents.

Try a reset first. Only takes a couple minutes. Many times the system loses it's memory and needs to be reset and relearn. The module learns the full open and full close positions of the doors.

Pull the fuse for the HVAC....turn the controls to full cold.....put fuse back in (needs to be out for a full minute) and turn the key to run position....do not start....allow the system to go through the relearn process....do not touch any controls....you'll hear it working the doors (takes less than a minute)....when finished start the car and see what you get...
I'm having related issues on my 08 (no heat to front vents, semi-warm air to rear). I tried to follow these directions but didn't hear the door moving so I want to make sure I'm doing it right.

Since the controls are electric I turned the key to ACC and set the temp to LO and turned off HVAC and car. Pulled A/CON fuse from under the dash and waited 1 minute. Inserted fuse and turned key to run (did not start). Didn't hear anything. Waited about 30 seconds and then turned the HVAC to the lowest fan setting. Didn't hear any changes in the air that would have led me to believe the doors are moving.

Should the HVAC be on or off when the key is initially turned? Just wanted to make sure I'm troubleshooting this correctly before I dig in. Thank you in advance.
 

·
Registered
Joined
·
7 Posts
2008 Veracruz. Finally did it. Fixed it with a blend door actuator replacement. Finally figured out how to remove the glove box housing. Just two "A-frame" clips held the housing in place. Pull real hard on the housing and the clips will let go (they may break). After the glove box housing was removed, and air ducts removed, replacing the actuator is very easy.
 

·
Registered
Joined
·
1 Posts
Hello, I hope it is okay to jump in on this old thread but I am having similar issues with my 08' VC. I have not tried to see if I can get different temps between passenger and drive but the air, hot or cold only comes out of the front vents. It will not move to windshield defrost of floor. My question is does the Blend Door Actuator control this process as well or is there another actuator I should be looking at. My research has indicated that there is a ‘Mode Actuator’ but I have no idea where to begin looking for it.
 
21 - 34 of 34 Posts
Top