Hyundai Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter · #1 ·
Hi Folks,


I have a 2013 Santa Fe Limited 2.0 with 235,000kms. My XM reception has been sketchy the past few weeks. I often get the "Check Antenna" error message on the display.


Although I haven't removed the antenna base yet, I'm anticipating some water damage, because everything on the outside looks fine.


I'm having trouble locating part numbers for the antenna base (and corresponding pole/mast). The dealer will not offer the part numbers without a deposit. The base is $264+tax CAD. I was hoping to find a cheaper solution online.


It doesn't look like the cheap shark fins will work, so I might have to go OEM.


Any help is appreciated.


Thanks.
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #5 ·

·
Registered
Joined
·
40 Posts
Discussion Starter · #6 ·
Pulled the headliner down enough to break a clip and get my hand in to loosen the nut on the antenna base. The connector was also a pain in the ass. Not much room without pulling the headliner down further and it looked like you'd need to let go of a lot of plastic in the rear. I managed to get the antenna base off the car and it didn't look bad, but it seems to be a sealed unti so I didn't play around with it. I did get a part number for those interested.

Hyundai P/N: 96210-4Z200 ANT ASSY-COMBINATION.

Can't find the part online anywhere. Going to have to order from the dealer. Boo.

On another note, has anyone tackled the "check antenna" issue before? Only when using xm radio. am and fm work fine. GPS works fine.

Cable and connector at the antenna looked fine. No obvious damage.
 

·
Registered
Joined
·
3 Posts
Just wondering if you had any luck with the "Check Antenna" issue?

I was going to see about dropping the back of the head-liner to get access to the antenna bottom, but was too hot this past weekend.

Thanks
 

·
Registered
Joined
·
90 Posts
Hi Folks,


I have a 2013 Santa Fe Limited 2.0 with 235,000kms. My XM reception has been sketchy the past few weeks. I often get the "Check Antenna" error message on the display.


Although I haven't removed the antenna base yet, I'm anticipating some water damage, because everything on the outside looks fine.


I'm having trouble locating part numbers for the antenna base (and corresponding pole/mast). The dealer will not offer the part numbers without a deposit. The base is $264+tax CAD. I was hoping to find a cheaper solution online.


It doesn't look like the cheap shark fins will work, so I might have to go OEM.


Any help is appreciated.


Thanks.


Just my 2 cents. Although this problem is normally due to the antenna, keep in mind that it could be at the other end; the radio itself, or lose connection or even the cable itself.


Cheers
 
1 - 10 of 10 Posts
Top