Hyundai Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
Hi all, I changed the oil on my wife's 2004 GX350 L, the first two times I started it sounded fine,


This morning she started it up (temp 30F) and for the first 10-15 seconds it rattled ridiculously loud but then quitted up real nice,

This is my first oil change on this car but don't get me wrong
I've done hundreds of oil changes,


She's always had it done at the place she bought it and lately at jiffy lube,


I remember a few years back having cold start rattle issues
after complaining they said they needed to use anti drain back filter and it was all good after that,


The Napa gold filter I used looked like it has the valve in it, I used Castrol 10-30 W oil,The filter that came out was a motor craft (jiffy lube),


I'm just wondering if the oil jiffy lube was using is a much lighter oil that
pumps up quicker or what??

Any thoughts?
Thanks in advance Jim
 

·
Registered
Joined
·
937 Posts
Why not use a genuine Hyundai filter and the recommended type and viscosity oil as per Hyundai. You then can be reasonably assured its not a oil or filter related noise. Cheers.
 

·
Registered
Joined
·
4 Posts
I know this thread in almost 2 mo old but I thought I would chime in. There is a TSB out about aftermarket oil filters, some do not have the proper ADV (Anti Drainback Valve) And recommend the OEM one. I have this issue as well, The OEM works well as do the mahle oc 330 from the aftermarket. Fram,STP,Purolator, K&N not so well for me at least.
 

·
Registered
Joined
·
3 Posts
Side note.. Check your oil level.. Just make sure its not over full... Ive had the same thing happen to me. Sure enough the level was over full. Once I drain some out and kept it between the low and full mark, Everthing is now ok and back to normal
 
1 - 5 of 5 Posts
Top