Hyundai Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I just picked up this 2005 Elantra last month. She runs GREAT - except after filling. Then she will occasionally sputter or sometimes stall during idle. Otherwise, if tank is below 3/4 (approximately), she runs fine. Can you help me out here?
 

·
Registered
Joined
·
8,613 Posts
Sounds like the evap solenoid is not working or the gas tank air filter is clogged. May be the evap hoses are kinked or colgged too.

To test leave the cap loose after filling. If it runs OK then the evap system is the problem.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
I just checked and that info is there.
Melbourne, Florida - 2005 Hyundai Elantra.
Am I missing something?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Thanks! - I will drive with cap loose and see if it helps.

When you say the "Evap solenoid"...are we talking the one in the Charcoal Canister...or somewhere else?
 

·
Registered
Joined
·
8,613 Posts
Thanks! - I will drive with cap loose and see if it helps.

When you say the "Evap solenoid"...are we talking the one in the Charcoal Canister...or somewhere else?

I have no idea where it is on your car.

Go to www.hyundaitechinfo.com and sign up. You need to use IE and allow popups. It will show you where the solenoid is if you dig deep enough.
 

·
Registered
Joined
·
1,978 Posts
Check for codes with scanner first.

Purge valve which can also be called a solenoid; located under hood on back of intake manifold, close to firewall.
You need intake air supply snorkel removed to change part and see it properly.
One 10mm bolt , two tiny hose clamps, one electrical plug held with retaining clip; 15 minutes approx change time.
 

·
Registered
Joined
·
17,552 Posts
1 - 8 of 8 Posts
Top