Hyundai Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
I've owned the car for about 2 weeks now, and I've gotten gas three times. All three times, when I've gotten back in the car, I go to start it, and it immediately stalls. I start it again, and it won't idle, so I have to keep my foot on the pedal for about a minute. After that, it's fine.
I'm not really bothered by it, but I am worried that it's a sign of something worse. It has never had any trouble starting besides those three times I've gotten gas.
 

·
Registered
Joined
·
3,151 Posts
start with the usual inquiry for more info:

- any check engine light? there could very well be error codes

- plugs should be checked for condition/colour to try to see if its running lean. that would be a good possibility.

- does it stumble? what does the car normally idle at? both from cold start (before it stalls if possible) and once warm.

- whats coming out the tailpipe when you start it up? any unusually large cloud of smoke? what colour if so?

- any other issues that may seem unrelated? coolant level? gas pump clicking off too early when you fill? anything you can think of.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #5 ·
start with the usual inquiry for more info:

- any check engine light? there could very well be error codes

- plugs should be checked for condition/colour to try to see if its running lean. that would be a good possibility.

- does it stumble? what does the car normally idle at? both from cold start (before it stalls if possible) and once warm.

- whats coming out the tailpipe when you start it up? any unusually large cloud of smoke? what colour if so?

- any other issues that may seem unrelated? coolant level? gas pump clicking off too early when you fill? anything you can think of.
I do have a CEL, but the only code is P0501 which is the speed sensor. It idles at 400 RPM when warm.
 

·
Registered
Joined
·
8 Posts
Purge valve!! For sure!!

Wifes 04 elantra gls would stall after getting gas. This was a faulty purge valve. Mechanic wanted to replace canister and valve, O rileys told me 90 percent of canisters are fine its just the valve.
Valve is hard to find. Stand by drivers door and reach behind engine and feel around. Towards firewall. Cant see it. Took me a hour to find and pull it.
Not hard to do just hard to find.
Youtube videos helped.
Fixed purge for like 30 bucks or something. never had trouble again fueling up, but I might have a faulty abs speed sensor right now ( like you>).
 

·
Registered
Joined
·
3,151 Posts
Wifes 04 elantra gls would stall after getting gas. This was a faulty purge valve. Mechanic wanted to replace canister and valve, O rileys told me 90 percent of canisters are fine its just the valve.
Valve is hard to find. Stand by drivers door and reach behind engine and feel around. Towards firewall. Cant see it. Took me a hour to find and pull it.
Not hard to do just hard to find.
Youtube videos helped.
Fixed purge for like 30 bucks or something. never had trouble again fueling up, but I might have a faulty abs speed sensor right now ( like you>).
the same thing i always say: TEST before replacing parts. unless you like wasting time and money and still have a car that doesn't work right when you're done.

although its a possibility, you have no proof of this what so ever. i would expect a bad purge valve to be accompanied with ECU codes. depending on which one it is can either be valve not working at all or valve isn't sealing when its shut.

there are plenty of other options. EVAP line could be damaged, charcoal canister could be trashed, clogged air filter on the tank if so equipped, and on and on.
 

·
Registered
Joined
·
4,851 Posts
the same thing i always say: TEST before replacing parts. unless you like wasting time and money and still have a car that doesn't work right when you're done.

although its a possibility, you have no proof of this what so ever. i would expect a bad purge valve to be accompanied with ECU codes. depending on which one it is can either be valve not working at all or valve isn't sealing when its shut.

there are plenty of other options. EVAP line could be damaged, charcoal canister could be trashed, clogged air filter on the tank if so equipped, and on and on.
A leaky purge valve doesn't make a code, and that's what we usually find around here. Only makes a code when it has an electrical fault.
 
1 - 8 of 8 Posts
Top