Hyundai Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I've got an 03 Elantra GT with 170k, and just gave it its third timing belt this weekend. Very easy job, thanks to some walk-throughs posted on this forum (kudos).

Put everything back together, and it started right up. After five minutes of driving, the check engine light came on. Scanned as code P0340 (camshaft position sensor). Picked one up, and before I put it in, I have some questions.

1. Where is it? I see something that looks like a good candidate on the back side of the head by the cam sprocket.

2. Before I replace it, I want to check the wiring harness. Since I don't have a book, what am I supposed to be getting on those three terminals?

3. Did I mess something up in the process of the timing belt replacement? I turned the engine over with a wrench a few times to make sure I didn't bend any valves when I started her up. Did this mess a sensor up?
 

·
Registered
Joined
·
17,552 Posts
Double check your timing marks from belt install..

Out of time synchronization of cam and crank will give you code. Sensor is at corner of head above A/C compressor.

I suspect you did not have this code until belt replacement ...
 

·
Registered
Joined
·
4,851 Posts
QUOTE (sbr711 @ Jul 6 2010, 12:26 PM) index.php?act=findpost&pid=339232
Double check your timing marks from belt install..

Out of time synchronization of cam and crank will give you code. Sensor is at corner of head above A/C compressor.

I suspect you did not have this code until belt replacement ...
Indeed, sounds like you got the timing belt off tooth or two. Take the top cover off and verify the timing belt installation.
 

·
Registered
Joined
·
17,552 Posts
We have found that the dowel pin on the cam has been falling apart on the end, and mess with waveform from the sensor..

Make sure belt time correct, and if come back, look at end of dowel to verify it is not chipped/broken, as you will keep replacing sensor, and wave form be no good. End repair there be new cam, and valve adjust if applicable
 

·
Registered
Joined
·
20 Posts
will a bad cam sensor cause a really bad misfire? becasue i ran the codes aat work and it came back with a cam sensor code.
 
1 - 7 of 7 Posts
Top