Hyundai Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hello Members

I was just wondering if any one has come across my problem, my 02 V6 Auto Santa fee (My Baby) isnt working.she has been in my brother-inlaws garage now for 2 months, now the problem is i was driving and suddenly it started to bunny hop and couldnt get up even simple hills, the hi scan said it was a cylinder problem, so changed the injectors, new fuel sensor, checked all the leads and fuses and still not working?

it turnes over very well but as soon as the revs go over 15 its starts to choke!

the compression test was ok

im stumpted and so is my brother inlaw who is a machanic?

He thinks it could be the ECU unit? can they be Repaired or Reprogrammed.i have made enquires, but as its a siemanns ECU unit i have been quoted over £1100.00 and been told they are difficult to repair, but we are not sure if that is the problem.

sorry if this all sounds up in the air, but i miss my Santa fe
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Thank you for your reply.
I will get the Hi-Scan results to you asap.
The mechanic has them,will be speaking to him tonight. sorry i seem disorganised, this has been going on for so long.
Thanks
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Hi Thanks for trying we did what you said todo, but still the same thing, and managed not to get Zapped!!!! :460:

i have managed to speak to a technician, who is going to test the ecu unit for me!!! as the car still turns over he thinks it could be an out put problem from the ECU unit! the Siemens ecu unit are difficult (5WY1245D) as its surrounded in slicone!!??

i will keep you all update.

Dave :liebe011:
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top