Hyundai Forums banner

1 - 20 of 20 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
So I have a 2013 Elantra Limited with the Nav system installed. I am running to an issue that I can't seem to figure out how to fix. I have tried with my iPhone and as well as other Android phones, when someone calls me, the name does not appear on my screen. For some reason it adds a +1 in front of the number so if the number calling is 732-555-555 and it's listed under John, it'll come up +17325555555 and not the name. I even tried putting the +1 in the contact in my phone. I have called tech support and it says it's a compatibility issue with the iPhone with iOS 7, but it was happening with iOS 6 and as well as Android Phones. I have AT&T if that helps the situation
 

·
Registered
Joined
·
3,510 Posts
Never seen that one before, with my 4s and IOS7 using AT&T as a provider same as you. In fact, no issues at all these days, unlike IOS6 which disconnected all the time. With the added number, does it dial correctly? Doesn't sound like it's the phone(s) at all.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
Yea I tried calling tech support and they said it was a known issue. What year make and model is your car? I have tried a 4s as well running iOS 7 and as well as Android Devices and it still doesn't work. Could I have a bum unit?
 

·
Registered
Joined
·
50 Posts
I have an iPhone 4 on IOS7 and AT&T service. All works fine with my 2013 Elantra. IOS 6 worked fine also. My wife has the same setup and it also works fine. No +1. Tell tech support that they are wrong about the compatibility issue.
 

·
senior member
Joined
·
22,788 Posts
My iPhone 4 had the occasional dropped call. But that's about it. Have upgraded to iPhone 5 with no changes in the numericals as far as dialing out with Bluetooth. Same car, same locale. It's business as usual. Hope this helps.
 

·
Registered
Joined
·
50 Posts
A little more information. I just went out to the car and downloaded the recent history of my bluetooth calls. All calls showed the name associated with them in my iPhone with the exception of a few calls answered where the number was not in my phone. These were regular 10 digit numbers.

Have you downloaded your iPhone to the address book in your Elantra?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #7
Yes I have it set to do it automatically every time I get in. It only happens with incoming calls, outgoing is fine.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #10
Oh ok, I am new, didn't see that. So when you get a call, it comes up correctly on your Nav screen?
 

·
senior member
Joined
·
22,788 Posts
Oh ok, I am new, didn't see that. So when you get a call, it comes up correctly on your Nav screen?
BTW, dirone, Welcome to the forum. :00000732:
 

·
Registered
Joined
·
13 Posts
Discussion Starter #12
And it is weird, when I go to my address book it has the correct names. It seems to be a weird glitch and only when iPhone people call me. Because as you may know there are three white boxes, the first one says the name of my phone, ones blank that displays the number when I get a call then the last one is a timer. When I get a call from an android phone the name of my phone goes away and the band of the caller comes up, the number is still messed up but thats ok because the name comes up. But when I get a call from an iPhone, the name of my phone doesn't go away and just shows the messed up number.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #13
Called tech support and the guy told me to call the service manager to have someone look at it. He said that should not be happening and that I might need a new unit.
 

·
Registered
Joined
·
50 Posts
Congratulations, you may find someone interested in your problem. That is half the battle. It is far easier for them to say "That is a known issue" and just leave you hanging. Don't give up.
 
1 - 20 of 20 Posts
Top