Hyundai Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
I seem to be having random bluetooth connection problems. Sometimes when I start up the car, it simply doesn't connect to my phone. Most of the time it works just fine, but its very frustrating on those random occasions when it does not. Any ideas as to what might cause this? :confused:

Also, does it have a priority connection? If both my wife and I have our phones paired with the car, and she drove it last (had her phone connected last) will it automatically connect to my phone if I am the next driver?

Thanks for the help
 

·
Registered
2013 Hyundai Santa Fe Sport
Joined
·
2,286 Posts
This is the quirk of the BT system in these cars. Not really much you can do about it.

You have a 2013 so your radio has newer BT firmware than mine. Sad to know that the system still sucks so bad.

Try unpairing both phones and clearing out the radio of any connected phones. Re-pair them, and make sure that they can access your contacts (on smartphones, you will be asked this as soon as the car accepts the PIN code).

As far as priority, on my car (I have the older 2011 small screen radio), the connected phones list shows the order in which the phones are prioritized to the system. So priority is the order in which you connected. It will always attempt to pair with the first phone on the list, then the second, and then so on (IIRC the system can hold up to 5 phones)

Again this is based on my experiences with my radio. Yours is newer so some things may be different.

BTW what make/model phones do you have? While theoretically any BT phone should work, I know that any Windows Mobile phone (the older ones not the new Windows Phone ones) have major issues with our BT system. Also other members that have/had BlackBerries also had some issues with functionality.
 
1 - 2 of 2 Posts
Top