Hyundai Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Can you please explain to me when and how often your Bluelink system updates itself by showing "Bluelink loading" on the screen. I don't know what is usual, mine seems to "load" often and for a long time. Please let me know your experience so I can deal with my problem, if it is a problem. Thanks.
 

·
Registered
Joined
·
113 Posts
Funny this came up. Mine was taking a good minute or two to load. Now its completely stuck on the loading screen and can't see climate setting or anything. Very annoying and haven't had time to go to dealer. So when I drive its fairly quite with a dead head unit.
 

·
Registered
Joined
·
122 Posts
Bluelink is the worst system. It was jacked up when I put got my 2012 Sonata and its still jacked up 5 yrs later! Network connections issues, long delays in starting my car, etc. Bluelink is also the worst at customer service. I got 0 reminders about my 90 day free trial ended and they billed my credit card, which I knew they would, but come on! Not one reminder?!?! Sirius was sending me emails once a week for 6 weeks and every day the last week that my service was about to end. When I called Bluelink to cancel my subscription, I had to be transferred twice and then when I told the lady on the phone I don't use their Navigation Service, "That's why I bought a car with Navigation" and that there service was unrealiable, she asked me if I disatisfied with the Service. Duh! She didn't even try to lur be back with a discounted rate. Just said thank you and hung up. Hyundai is missing out on this Service. It could be a money maker but who wants to pay $300 to remote start your car.
 
  • Like
Reactions: erieviewer

·
Registered
Joined
·
1,543 Posts
I guess I must be lucky. While it is pricey it has generally always worked for me. I can only think of one time when I received a "not available" type of message. The remote start is not immediate but for me it is usually no more than a 20 second delay which I find acceptable.

Not thrilled with the Bluelink Nav function on our 2015. That can be a bit quirky at times but the vast majority of the time it does work.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Hey guys what I am trying to determine what the NORMAL operation of Bluelink is. How often does your system seem to update, my system seems to update frequently taking over the Nav screen, cannot use bluetooth phone or see anything on screen, except it will allow the backup camera to work, however without the yellow and green grid outline.

I've been to the dealer who "rebooted" the system, it appears to "phone home less". I use the vehicle very little, like every other weekend, so it may appear to update more frequently and longer than a person who uses the vehicle daily and may not notice the "intrusion." Can you let me know it will really help me out.
 

·
Registered
2017 SFS 2.0 T Ultimate
Joined
·
769 Posts
Hey guys what I am trying to determine what the NORMAL operation of Bluelink is. How often does your system seem to update, my system seems to update frequently taking over the Nav screen, cannot use bluetooth phone or see anything on screen, except it will allow the backup camera to work, however without the yellow and green grid outline.

I've been to the dealer who "rebooted" the system, it appears to "phone home less". I use the vehicle very little, like every other weekend, so it may appear to update more frequently and longer than a person who uses the vehicle daily and may not notice the "intrusion." Can you let me know it will really help me out.
I've only had my car a month, but I think I've only seen it do that once. Granted, I'm usually doing other things while the "system" is booting up and it's sitting on the "confirm" screen. Plus it gives me the 30-60 seconds for the turbo to warm up before I do anything. Although I also plug my iPhone into the head unit so I also have to wait for Carplay to fully initialize.

But then again I have a 2017 SFS with the latest firmware update, and am still on the trial BlueLink.
 

·
Registered
Joined
·
113 Posts
Finally made it to dealer, I'm getting a brandy new nav unit installed due to the blue link loading screen issue. 24k miles on my 14 SF sport
 

·
Registered
Joined
·
1 Posts
Hi, Everyone,

I have an Elantra Sport 2015. My Blue Link would take 15 minutes to load in the morning. Then it would work fine all day. I took it to the dealer. They swapped in a new console device. Apparently I have an older hardware model and CANNOT be flashed with new firmware. So if you are having "Blue Link Loading" problems, get to a dealer. Even though you may be over your 3/36 warranty, they will swap you out as a token of "good customer relations."

Hope this helps someone.
 

·
Premium Member
Joined
·
242 Posts
Hyundai MapNSoft NAV SUCKS

Not thrilled with the Bluelink Nav function on our 2015. That can be a bit quirky at times but the vast majority of the time it does work.
The NAV System Sucks. Yesterday I was sitting in the parking lot of a location I had programmed in and the NAV System kept telling me to proceed and make a U Turn. I don't know where it was trying to send me. Once in Orlando, I was trying to find a location and the Nav System kept telling me to make a U Turn again and again. Turns out I kept passing the street I need to turn on but the NAV did not tell me. USELESS in my opinion. :frown:
 

·
Registered
Joined
·
10 Posts
No issue with either or my two '18 SFS's Ultimate with tech. Love the remote start and there is usually a 20-30 second delay which I can live with. I prefer WAZE and I have done the free Nav upgrade not so much for the maps, but for any firmware that comes with it. Hard to understand if improves anything, but is free for me so why not.
 

·
Registered
Joined
·
11 Posts
What do you lose without Bluelink

About 3-4 months ago I bought a 2016 CPO'd SFS Ultimate. The Bluelink trial is ending and when I told them I didn't want to renew, they told me the nav would no longer function. Could that be right? The Bluelink service itself was terrible. When I would remote start, it would flash my lights, like the car was being stolen. For that reason alone, I wouldn't renew. I have a remote car starter, so can start my car when I am close by. There were no other features I cared that much about.



But I am not clear how much functionality I will lose on my built in Nav system. Bluelink wasn't helpful other than to scare me that unless I renewed I wouldn't have GPS. Can anyone clarify?:frown:
 

·
Registered
Joined
·
4 Posts
Can you please explain to me when and how often your Bluelink system updates itself by showing "Bluelink loading" on the screen. I don't know what is usual, mine seems to "load" often and for a long time. Please let me know your experience so I can deal with my problem, if it is a problem. Thanks.
I have a Hyundai Santa Fe Sports 2016 with the big 8" Screen. My Bluelink takes 20 to 30 minutes to load in the morning. It should take about 1 or 2 minutes at most. Anybody have these issues and a fix. My dealer said it is out of warrenty and I have to buy a new once which would cost several $1,000 dollars. I tried reseting it by pushing in the little pin button on the outside but that did not help. Still took a **** of a long time to load. After it loads it is ok - run GPS, NAV, great but. So, its the inital loading in the morning. I am also finding it getting longer to load if I make a quick stop at the store and come back to my car to restart it as well, however: not as long to fully reboot / loading. The radio works find but it will not connect to my bluetooth phone or load GPS until 20 to 30 minutes.
 

·
Registered
Joined
·
4 Posts
I have a Hyundai Santa Fe Sports 2016 with the big 8" Screen. My Bluelink takes 40 minutes to load in the morning. It should take about 1 or 2 minutes at most. Anybody have these issues and a fix. My dealer said it is out of warrenty and I have to buy a new once which would cost $4K. I tried reseting it by pushing in the little pin button on the outside but that did not help. Still took a **** of a long time to load. After it loads it is ok - run GPS, NAV, great but. So, its the inital loading in the morning. I am also finding it getting longer to load if I make a quick stop at the store and come back to my car to restart it as well, however: not as long to fully reboot / loading. The radio works find but it will not connect to my bluetooth phone or load GPS until 40 minutes
 
1 - 13 of 13 Posts
Top