Hyundai Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi,

I have a 2013 Sonata Hybrid which included free trial of 3 year Assurance package and two other packages for 3 months. I didn't use them much, but sending POI from computer or phone to the car began to fail after about a month. I simply got a message saying "Blue Link is not active. Contact the customer service ~". Since I didn't use it much, I didn't pay much attention to it, but came to realize that the even the Emergency button did not work at all.

I contacted the Blue Link Customer service by phone as instructed in early October, and I was told that their resolution team would work on my issue shortly. Ever since then I emailed and phoned multiple times, all I got back was that their resolution team would be working on it.

After THREE months, one of their representative contacted me saying that they resolved the issue so that I could go ahead try within the new few days. Alas, the issue was still NOT resolved. So, I contacted them again multiple times and all I heard back was again their resolution team would be working on my issue shortly.

Guys, it's been FOUR months and this is the worst customer service that I have ever had. Has anyone experienced this poor level of customer care from Blue Link? Any suggestion would be greatly appreciated.

Thanks,
Junguk
 

·
Registered
Joined
·
350 Posts
Sound like they are on par with XM's customer service. Took nearly 6 months of calls and emails to get that free trial working on my 2011.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Maybe XM and Blue Link work together. One of the emails I got from Blue Link regarding my issue was actually copied to two email addresses from siriusxm.com. I might have to wait another two months.
 

·
Registered
Joined
·
34 Posts
Dealer promised the service, I'd swing the topic back towards them.

I had an issue: Bought 2 2013 HSH, and the dealer created 2 different "myhyundai.com accounts. That made it difficult for me to use 1 iPhone to remote start both cars.

The app does not allow for a second, identical app to be loaded to the iPhone, so I needed both cars in the same account.

Took a month, a few calls, but, today, it works. It helped to swing back towards the dealer, even while dealer was pointing at blue-link. The dealer's call to blue link helped me resolve this.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
I already brought that issue to the dealer, but she said there was no issue with the hardware and asked me to keep calling and emailing to the Blue Link Customer Care team. Not much help from the dealer. -_-;;
 

·
Registered
Joined
·
592 Posts
Thinking out loud here (after looking at BlueLink and XM in some depth)...

BL works throught the installed modem (behind the radio) and the shark fin antenna. The BL system uses the Verizon network to communicate. If the Verizon signal is poor, BL doesn't work.

This is not to say that the BlueLink system isn't at fault, just saying you have three major elements to troubleshoot:


  1. The BlueLink system
  2. The Verizon network
  3. Your vehicle hardware
Regards,
GEWB
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
Hi GEWB,

Do you think it's better to take the car to the dealer shop (service center) to examine the hardware? Last time I asked them to take a look at it and I was told that it was not a hardware problem. I don't know how thoroughly they examined it.

Thanks,
Junguk
 

·
Banned
Joined
·
532 Posts
When a mechanic does any work to Bluelink there's a series of commands, said in the vehicle to confirm the work done on the hard side of the system with replies from the vehicle, either vocally or on screen. Not doing the proprietary vocal's may not finalize the work done to the system this is for work done by the dealership and mechanics only. Bluelink work and updates can always be confirmed OTA by them almost instantaneously during a call. Also, from a repair aspect they can't take a unit from another car on the lot and do a swap out, you need a new unit, then initialization of that new unit to the cars ECU and VIN followed by a series of commands and OTA confirmation's from BL.

It is a very long, frustrating process you've been through and unacceptable, I'm also sure they don't like the situation.

Two questions: 1) Do you have one case # or multiple's ?, multiple #'s screw up any trouble shooting, if multiple ask to centralize them under a new case #. 2) Have you asked to escalate the issue ?, If not ask them to, get that persons extension, then ask for a person they suggest to speak with if they're not available. They work in an "open type or cubicle type area" they can see who's on the phone, etc.- learned that little tip during a call by being pleasurable, story telling, politeness, a few bad jokes and a thankful attitude. Again, it stinks it's gone on so long but it can only roll uphill now.

Good luck, it'll get fixed and soon you'll be ..... :auto: along with a big ..... :D on your mug.

:cool: ..... And no, I don't work for BL, HMA, Dealer or any other interest ... read your mind, didn't I ..... ^_^ ..... Just trying to pass along tip's and help, on an open forum in a very & long wordy post ..... :cool:
 

·
Registered
Joined
·
592 Posts
Hi GEWB,

Do you think it's better to take the car to the dealer shop (service center) to examine the hardware? Last time I asked them to take a look at it and I was told that it was not a hardware problem. I don't know how thoroughly they examined it.

Thanks,
Junguk
I like jd's reply.

As for me, I refuse to use BlueLink or XM and had them unplugged.

Regards,
GEWB
 

·
Registered
Joined
·
6 Posts
Discussion Starter #10
Thank you very much jd.

There is only one case number and I already asked them to escalate my issue to higher level. I was told that my case was being investigated by the Resolution Team. ^^

I was actually contact on Saturday from the Blue Link Resolution Team notifying they might have fixed the issue and check my vehicle again to see if I would get any difference response with those buttons. Unfortunately, I still have no luck with these buttons, still saying "Blue Link Not Active". I haven't got back to them yet, but will later this afternoon.

Thank you again.
Junguk
 

·
Registered
Joined
·
474 Posts
Blue Link is OK

My '13 Elantra GT came standard with Blue Link. I bought the Essentials package because I like being able to lock and unlock the doors remotely. I installed the BL App on my Galaxy S2 phone and it worked fine until I did the latest update in late January '14. The update failed to work at all. I messaged and called Hyundai directly. They did release another update this week and it's working well again.
I'll probably go ahead with the full package, Essentials and Navigation for the next 2 years. If you buy it all you get a better rate too.;)
 
1 - 12 of 12 Posts
Top