Hyundai Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi everyone, I'm Belle & I'm a newby to this forum (still trying to navigate it) & I'm hoping that someone might be able to offer their voice of experience.
My sprint (sohc, 1.5l, efi, 5 spd & 153,000 kms) just developed top end noise and baulks & loses power under acceleration.
Fuel flow seems good, new plugs, changed leads, changed the coil pack and that didn’t help, all looks ok under the rocker cover, timing belt done at 95,000 kms. Added injector cleaner to fuel & no change (filled fuel tank 2 days before, cheap fuel?).
Any suggestions will be greatly appreciated.

East Victoria, Australia

Thankyou
Belle
 

·
Registered
Joined
·
5,231 Posts
Hi everyone, I'm Belle & I'm a newby to this forum (still trying to navigate it) & I'm hoping that someone might be able to offer their voice of experience.
My sprint (sohc, 1.5l, efi, 5 spd & 153,000 kms) just developed top end noise and baulks & loses power under acceleration.



Fuel flow seems good,


How's that?



new plugs, changed leads, changed the coil pack and that didn’t help, all looks ok under the rocker cover, timing belt done at 95,000 kms. Added injector cleaner to fuel & no change (filled fuel tank 2 days before, cheap fuel?).
Any suggestions will be greatly appreciated.

East Victoria, Australia

Thankyou
Belle
Scan it for codes.


00000732


Best practices for requesting help:If you haven't done so fill in your vehicle info and profile page. At upper right corner under the search box click on user cp (it's your control panel)
This info will show up to the left under your user name and is very helpful.
BE SURE TO ADD YOUR LOCATION SO WE KNOW WHAT MARKET YOU ARE IN.



  • Be sure you are in the correct forum for your vehicle.
  • Do a search for your problem. A lot of stuff has been asked and answered.
  • Do not double post for the same problem.
  • Give the model year....Engine size...transmission type (auto or standard)
  • Take a single issue at a time. Posting multiple issues at once will get convoluted very quickly
  • VIN number can be very helpful
  • Vehicle history can be good. How many miles. If not bought new, how many have you put on it.
  • Describe the problem best you can. If a noise can you get a sound or video file
  • Tell us what has been done, if anything, thus far. If tests have been performed give actual results not OK or passed. If scanned for codes the actual code(s) not O2 sensor or MAF, Etc.
  • If the vehicle has been to a repair facility it would be nice if you could post a picture of that invoice/bill
  • If your vehicle is under warranty you should have the dealer check it out. If it's a problem they see many times they will generate a safety recall of TSB. This is how they know of the problem.

This information can save a lot of time and get you the answers you need much faster.


Thanks,
Welcome aboard.
 

·
Registered
Joined
·
12,158 Posts
My sprint (sohc, 1.5l, efi, 5 spd & 153,000 kms) just developed top end noise
Can you describe the noise? Is the noise constant or is it only heard when the engine baulks & loses power.

Fuel flow seems good
Good fuel flow is meaningless. Fuel flowing out an open pipe doesn't necessarily mean the pump can build pressure in the fuel rail. You'd really need to check that the fuel pressure is correct when the engine baulks & loses power. That's the only fuel test that is relevant, but to test it requires special equipment that your not likely to have.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4 (Edited)
Hi again, I've had a computer diagnostic done & it picked up that the cam shaft sensor was faulty. Easy fix 😆

Thankyou to those who offered guidance.

Have a great day ☺

Belle
 
1 - 4 of 4 Posts
Top