Hyundai Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I plugged something into my OBD2 port which I believe blew something, hopefully just a fuse but I am thinking its the BCM.

These are the issues.

The OBD2 now doesnt get any power.

The Trunk release button only works when car is powered on.

The power doors will only lock with the car on and the door closed.
With car on and door open I can unlock the doors only but not lock.
With car off power locks dont work at all.
The smart key will not lock or unlock the doors at all but it will make the car make a beep sound when the unlock button is pressed.

Any advice?
 

·
Registered
Joined
·
1,327 Posts
Your first step would be to check all the fuses.
If that doesn't change anything I would disconnect the battery for a few minutes and see if that resets the BCM but it sounds like you messed something up good.
You still under warranty?
 

·
Registered
Joined
·
17,552 Posts
DVOM is your friend
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Your first step would be to check all the fuses.
If that doesn't change anything I would disconnect the battery for a few minutes and see if that resets the BCM but it sounds like you messed something up good.
You still under warranty?
I will do this. I checked a few and so far nothing. I will try to disconnect the battery afterwards to.

I am not under warranty. Luckily it doesn't mess with the functionality of the car and my emissions aren't due till January so its just a inconvenience right now. After researching quite a bit, I am leaning towards needing to replace the BCM as the likely scenario.


Thanks for your replies
 

·
Registered
Joined
·
403 Posts
Just out of curiosity, what did you plug in that caused issues? If it's a faulty OBD2 scanner or something similar, would be nice to know to avoid. Good luck.

Sent from my SM-G930P using Tapatalk
 

·
Registered
Joined
·
17,552 Posts

Attachments

1 - 9 of 9 Posts
Top