Hyundai Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Can anyone explain how this works?

It doesn't remember where it was when I turned off the ignition.

It always starts with poor economy, like 15 mpg and slowly [10 miles] moves up to around 28 mpg.

Ken C
 

·
Registered
Joined
·
2,457 Posts
:puzzled: Sounds like its resetting at each start-up...does in display ECO when warmed-up? Maybe that is turned-off in setup?
 

·
Registered
Joined
·
827 Posts
Is it like that as soon as you turn on the car? Or do you turn it on and then leave it running so it warms up before actually driving?

Sent from my VS995 using Tapatalk
 

·
Registered
Joined
·
186 Posts
There is a setting for how that display behaves. I have mine set to reset each time I start the car.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
There is a setting for how that display behaves. I have mine set to reset each time I start the car.
Correct: Off|Each gas fill|Each ignition

How does it know if you have gassed up? Does it store gas tank level in non-volatile memory?

Ken C
 

·
Registered
Joined
·
207 Posts
There are a lot of things stored in NV memory, and some of them are not even that visible.
For example, even if I reset my average consumption, the range is still calculated on the previous values and updates as I drive onward as if I've never reset the average (I guess it must keep a separate average for the last 5-10 km or so).
 

·
Registered
Joined
·
39 Posts
My average MPG display seems to randomly reset at startup. Most of the time it only resets when I refill the tank. But over the last couple of months, it seems to be randomly resetting at startup, maybe once every 3 or 4 starts. I've owned my 2017 for more than a year now and it never did that in the first 8-10 months. Anyone else seeing random reset behavior of the average MPG display?
 
1 - 8 of 8 Posts
Top