Hyundai Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
206 Posts
Discussion Starter #1 (Edited)
It has been addressed but I figured I would add something I tried. I just picked up a used 06 Limited and the auto climate controls seemed to have an issue with maintaining the temperature(heat) When I turned it on it seemed ok. If I turned it off of MAX heat it would drop to pushing cold out of the vents even set in the 80s. I checked the mixer doors and they worked great with the car off and adjusting through the whole range. I narrowed it down to the sensor behind the vent in face of the controls. The sensor is a simple thermistor with a very small brushless motor fan that has to pull the cabin air in past the sensor to effectively manage the temperature. Mine was caked with a big hunk of dust not allowing it to spin. I cleaned it and it was still intermittent. I took apart the sensor removing the end cap and removed the fan, control board and shaft. It looks like the shaft has a simple carbon bushing. The shaft was binding just enough to not allow the little fan coil to get it spinning. I put a little "dry" lube on the shaft and that seems to do the trick for now. The sensor assembly is $100 so we'll see how long it lasts. I imagine all the failures and issues with these unit are all attributed to the fan failing vice the actual sensor component itself or electrical controls failure. A small filter would've probably alleviated all the reported issues with these auto controls.
 
1 - 1 of 1 Posts
Top