Hyundai Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1 (Edited)
hi ive a 2007 amica, its been parked up after a crash , had front wings bonnet, rad replaced , the car wont start ,had immobiliser light on so fitted another one light goes out ,but still will not start ,plugged my snap-on ethos in it just says no power from car , so tried obd11 and got 1690 code , any help would be appreciated ,
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
13,407 Posts
Did you erase the trouble code, and did it come back again?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
yer , I have an identical spare car that was a runner , taken immobiliser ,ecu , and pick up coil for ignition , put remote out that matches immobiliser in to key think i've swapped all I need for immobiliser side , still wont start and still come up with code ,I've also done the clutch not sure if that's anything to do with it ,
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
13,407 Posts
I think the 1690 code means there is a communication error between the SMARTRA module and the engine ECU. Since you've swapped all the parts over that would seem to point to the wiring on the car. I think a sensible first step would be to check that the SMARTRA module has a good power supply and ground.

Connector pinout below:
Terminal 1 & 2 are the wires from the ring antenna.
Terminal 3 is ground, 4 is the power supply (12V with ignition on), 5 is the communication wire leading to the engine ECU.
443864
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
I think the 1690 code means there is a communication error between the SMARTRA module and the engine ECU. Since you've swapped all the parts over that would seem to point to the wiring on the car. I think a sensible first step would be to check that the SMARTRA module has a good power supply and ground.

Connector pinout below:
Terminal 1 & 2 are the wires from the ring antenna.
Terminal 3 is ground, 4 is the power supply (12V with ignition on), 5 is the communication wire leading to the engine ECU.
View attachment 443864
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
still no joy one of the wires of rf coil is broke .am I right in thinking that the coil will have to be the one matched to the immobiliser !, its broken from the plug so use plug and wire from other coil and solder them
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
13,407 Posts
No, the RF coil (ring antenna) is just a coil of wire. It's not coded to the car in any way.
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
13,407 Posts
The immobilizer light should be on when you switch the ignition on. It should switch off during crank if engine start is authorised.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #10
does that now , still wont start ,swapped crank sensor and cam sensor ,with no joy ,only thing is both car's had a small accident one rear other front , is there a fuel cut off , or a relay that would trip its now doing my head in lol
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
13,407 Posts
Have you checked the basics? Is there fuel being delivered to the engine during crank? Is there a spark at the plugs?

I don't think there is a fuel cut off (inertia switch) on the Amica.
 

·
Registered
Joined
·
4,241 Posts
So, immobilizer has been ruled out??
Go back to basics
Check for fuel ... injector pulse (test light), fuel pressure at rail, fuel pump running
Check for spark at plugs
Listen to engine while cranking. Is it spinning too freely? Or not fast enough??
 
1 - 12 of 12 Posts
Top